Anchor tag not working in Safari

  • 1
  • Question
  • Updated 6 years ago
  • Answered
Hi, on my site I have several anchor tags that work on Firefox but not on Safari. Is there a known problem with this and, if so, is there a solution. You will find buttons on the about, audio for video, and what i do pages. Thanks for checking into this. Nancy
Photo of Nancy

Nancy

  • 6 Posts
  • 0 Reply Likes
  • frustrated

Posted 6 years ago

  • 1
Photo of Crystal

Crystal, Champion

  • 250 Posts
  • 79 Reply Likes
Hello Nancy, I was just reading the following web page http://forums.devshed.com/html-progra.... It appears that if you change the anchor to the full name http://www.mysite.com/pagetwo.php that they should then work in Safari.
Photo of Nancy

Nancy

  • 6 Posts
  • 0 Reply Likes
Hi Crystal, Thanks for the advice but it didn't work when I tried.
Photo of Nancy

Nancy

  • 6 Posts
  • 0 Reply Likes
Actually, I just discovered for the anchor tag to work in Safari, I needed to go to the live page, add the anchor tag (#name) at the end of the URL, copy that from the browser, and then use it in the backend link. Even though it read the same as when I simply added the anchor tag manually onto the link, picky,pick Safari wanted it done the other way. All is well now.
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Nancy

I'm happy to hear that you've been able to sort it out. Thank you so much for sharing the solution on our forum!
Photo of Nancy

Nancy

  • 6 Posts
  • 0 Reply Likes
I have anchor links on my site and they work in Firefox but not Safari. Please help.

This reply was created from a merged topic originally titled
My anchor links don't work on Safari..