auto prefix on links

  • 1
  • Question
  • Updated 5 years ago
Does anybody have any idea why that whenever I post a link - even if the file is on Yola - the sitebuilder puts the prefix:

web.archive.org/web/20050601005345/

My Yola site with a problem is woolwich.yolasite.com.

Example:

http://web.archive.org/web/2005060100...

The archive.org is a site I have used in a previous link on the page - sitebuilder even does it to that:

http://web.archive.org/web/2005060100...

Thanking you in advance for any input.
Photo of Garry Anderson

Garry Anderson

  • 4 Posts
  • 1 Reply Like

Posted 5 years ago

  • 1
Photo of Garry Anderson

Garry Anderson

  • 4 Posts
  • 1 Reply Like
Do the Yola moderators not have an answer to this please?
Photo of Jen

Jen

  • 206 Posts
  • 24 Reply Likes
Good day,

It looks like you copied and pasted some text from probably another source that contains some JavaScript referencing the Wayback Machine. This script contains the line "url = url.replace('.wstub.archive.org" which is replacing your URLs.

I created a test page and removed the JavaScript and this removed the URL replacement:

http://woolwich.yolasite.com/index-te...

The JavaScript is in approximately the 4th Text Widget underneath the text "There is lots more to tell - come back soon." You can access it in Sitebuilder by clicking in the Text Widget then clicking the HTML button on the text editing toolbar. If you scroll to the end of the text, you will see the script. You can just highlight and delete anything below your written text.

I hope that helps!
Photo of Garry Anderson

Garry Anderson

  • 4 Posts
  • 1 Reply Like
Dear Jen

Thank you very much - most kind.

Regards,

Garry