background scrolling

  • 1
  • Question
  • Updated 6 years ago
  • Answered
hey i have changed my css and now the scroll with page is not working. anyone know how to fix this?
Photo of Amanda Leigh Marianne High

Amanda Leigh Marianne High

  • 51 Posts
  • 2 Reply Likes

Posted 6 years ago

  • 1
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Amanda

When I look into your Yola account, I can see a lot of websites. For which of your sites did you change the CSS? Can you also let me know what exactly you changed?

A frequent error made with the Site CSS is that users copy the whole original code to the overrides field on the left-hand side of the CSS Editor. Only the code sections that you want to change should be added to the overrides field and then customised. Otherwise it's possible that things you set and want to keep will be overwritten.
Photo of Amanda Leigh Marianne High

Amanda Leigh Marianne High

  • 51 Posts
  • 2 Reply Likes
Hi there. Its the tickadeeboo site. All i want is the tree down the side of most of the pages to stay in the same place when people scroll the page.
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Amanda

I wasn't able to find a website with this name in your Yola account amandasalsa@gmail.com. Have you got another account with us? Can you please give me the domain name of your website?
Photo of Amanda Leigh Marianne High

Amanda Leigh Marianne High

  • 51 Posts
  • 2 Reply Likes
Yes i do. Sorry. highimpactnz@gmail.com is my other account and www.staginghome.co.nz is the website
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Amanda I think this that you ahve used the squeaky clean style with your own background?

If so then you can set the scrolling feature on/off on the background insert facility.

Style>Edit backgound



I'm guessing this image is how your currently looks and should be changed to:
Select "Scroll with page" option and Save.

Hoping this will get you there.
Photo of Amanda Leigh Marianne High

Amanda Leigh Marianne High

  • 51 Posts
  • 2 Reply Likes
tried that and it did not work. Have a go at it if you like but it will do it instantly but then as soon as I go out of the page or publish it it wont work :-(
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Ohhhh...

Try "revert to defaults". Save. Go out and come back in and then retry again.

Apply to all pages as well. I've noticed that if you make a few alterations of this facility, that it seems to get caught up but can't quite work out the logic behind it. The reset I described has worked previously and hoping this is your solution.

Gop
Photo of Amanda Leigh Marianne High

Amanda Leigh Marianne High

  • 51 Posts
  • 2 Reply Likes
tried that and it shows initially and then reverts back :-(
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
I'm stumped Amanda. Hoping that Yola staff can give you a solution. Sorry it hasn't worked out as yet.
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Amanda

I was able to check your Yola account and the specific website, and it seems the problem is exactly what I was presuming. When I check the overrides in the left box of your Site CSS Editor, it looks like the complete original CSS code which can viewed on the right under the "Site CSS" tab was copied over to the left-hand side overrides field. This is unfortunately not the correct way to edit your Site CSS. If you change your CSS as you indicated above, you must make sure that you only add those code sections to the overrides field which you want to change.

To test this please follow these steps:
  1. Disable your CSS overrides for now by checking the box in the bottom left of the CSS Editor.

  2. Go back to Sitebuilder and add your background image. Make sure to check the "Don't scroll with page" box in the dialogue box as Gop showed you above.

Now it should be working. If it still doesn't work, please provide the name of your background image for me to find it in your Yola File Manager, and I will investigate further.

If it does solve the problem, please go back to your CSS Editor, uncheck the disable box, and remove all code which would repeat the original code. The most important line will be in the body tag where it says "background-attachment:scroll;". This line must be removed from the overrides field because it tells your background image to scroll while you want it to be fixed.

Let me know if you need further assistance with this.