Banner background colour not transparent

  • 1
  • Problem
  • Updated 6 years ago
  • Solved
Hi Sanja,

I have sent two emails and have had NO response with regards to this issue and I'm getting really frustrated with Yola's support team as I'm not receiving ANY.

I need to publish the site that I'm working on and cannot do it unless this issue is sorted.

I have uploaded a .png file with a transparent background and it worked on my Home Page. Now that I've uploaded it to my About page it does not work. A white background appears in the background.

Please urgently indicate what the solution to this problem is as I know it is possible because it worked the first time round.

Thanks.
Photo of Lei Ling

Lei Ling

  • 174 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 1
Photo of Lei Ling

Lei Ling

  • 174 Posts
  • 0 Reply Likes
I've uploaded the same image through the picture widget and it appears with a transparent background! This proves that it's a Yola banner background issue and not the picture.
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Lei Ling

I wasn't able to find an e-mail conversation with our Support, using the e-mail address you have with your Support Forum account. Can you please provide the e-mail address you used? If you used your Forum e-mail, I'm afraid that we didn't get your e-mail.

I'd also like to ask you to stick to one Support Channel which you prefer. Using e-mail, the Forum and the Yola Call Centre on the same topics can be confusing and slow down the process of assisting you. Please also note that the Yola account I found in our system by your Forum e-mail is a Yola Free account which is entitled to basic support. If you upgrade to one of our paid hosting packages, Yola Bronze, Yola Silver, or Yola Gold, we will be able to offer you Priority E-mail Support (provided you use your sign-up e-mail to contact us).

With regard to the issue you posted about above: I will also be able to assist you with this as soon as I know your URL to track your Yola account in our system.

Thank you for your understanding.
Photo of Lei Ling

Lei Ling

  • 174 Posts
  • 0 Reply Likes
See test website to prove what I'm talking about. The banner pic and the pic in the pic widget is exactly the same!
http://TestD.yolasite.com
Photo of Lei Ling

Lei Ling

  • 174 Posts
  • 0 Reply Likes
Hi Stephan,

It's delite@starmail.co.za and addressed to Sanja. The reason for me calling the call centre was because there was no support on this forum from any employees except for Gop who does not work for Yola. Secondly I was asked to send an email through explaining my issue which I did and was told I would receive a response within 24hours. Thirdly I am on the Yola Silver package which means I should have received Priority email support but I haven't. Honestly the support has been terrible from your offices and I'm shocked. I am paying for this service and this is not the quality I was expecting.

See link above and please assist urgently as the site i'm working on needs to go live.
Photo of Lei Ling

Lei Ling

  • 174 Posts
  • 0 Reply Likes
I am waiting on a response?
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Lei Ling

Thank you for your information. I still haven't managed to find your e-mail you said you sent to Sanja, using the e-mail address you provided above. I'm sorry, but it seems we didn't receive it.

I apologize if our Support hasn't been to your satisfaction. The Support Forum is meant to be "users help users" in the first place, and for posts which don't or can't get answered by the Yola Community, our support reps offer assistance. We've been seeing your threads on our Forum, but as Gop has been greatly helping you, there was no need for us to add on those threads. I remember that there is one post where I tried to add on, but eventually you were better served with Gop's assistance because he had a deeper insight having helped you from the start.

I have checked your website testd.yolasite.com in your Yola Sitebuilder, and I can see that CSS code has incorrectly been added to the CSS Editor. The left-hand CSS Overrides box partly contains doubled code (original code) which hasn't been properly closed with a bracket (}). I can't find an "About us" page, either, it's only your Home page and a Contact Us page, and the banner background displays white for me on your home page while there is no custom banner on the Contact Us page.

When I look at your website, is it correct that you'd like to have a completely black background for your whole site? If so, you may probably not need to edit your Site CSS, but you can choose a black background option from the Style menu. Can you please try this and let me know if that helps? To do this:
  1. In the Style Gallery displayed in the lower menu bar, scroll to your current Style which you can identify by the blue "V".

  2. On the right-hand side of the Style thumbnail, you will see more background colour options for this Style. Click on the black square to choose a black background.

After changing your Style, the Site CSS will be disabled, and you can remove or edit them later if needed. Now you will need to re-add you banner image because you changed the Style. Please do this and let me know how that goes.

If this is not what you want to achieve or you'd like to change font colours or other basic things, please let me know, and I'll be happy to give you the necessary instructions, also for your CSS if needed.
Photo of Lei Ling

Lei Ling

  • 174 Posts
  • 0 Reply Likes
Hi Stefan,

The site link I sent was a test site and not the one I'm currently working on. The reason for me sending that link was to indicate the BANNER BACKGROUND ISSUE SHOWING WHITE AND NOT TRANSPARENCY and not the background to the whole site. Give me your email address and I will forward the emails to you directly now. The black background has been set for a reason and it does not affect the banner background clearly so no need to raise that point. I am also aware of how to change the background without the CSS. I applied it to the CSS for the entire site.

Please lets deal with the issue at hand which is the banner background issue as you're deviating from my original query. Lets just focus on this for now PLEASE.

What is the SOLUTION to getting the banner background section transparent? I need step by step instructions PLEASE.
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hi Lei Ling

If you prefer e-mail Support, please send your request to support@yola.com and add Attn Stefan to the subject.

The code for making the banner section transparent may not be the same or applied to the same area of the Site CSS of any Style, so I will need to know your proper website for which you'd like to apply the change. Please let me know the URL of this site, or, if you haven't published, the site name, so that I can find it in your Yola account. I will need to test the code needed for your background to go transparent before I can safely provide it for you.

If you're comfortable with sharing the required information on this thread, I'll also be happy to sort out this issue together with you here! :-)
Photo of Lei Ling

Lei Ling

  • 174 Posts
  • 0 Reply Likes
I've sent you two separate emails with the requested information. Kindly confirm if you've received both?
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Thanks. Until now I have only received one, but I hope this will be enough for me to help you. I'm looking into it asap, and follow up with you via e-mail.
Photo of Lei Ling

Lei Ling

  • 174 Posts
  • 0 Reply Likes
Hi Stefan,

Will un-publishing and re-plublishing my site work quicker to solve the problem?
Photo of Lei Ling

Lei Ling

  • 174 Posts
  • 0 Reply Likes
THANK YOU! Stepan! I got your email and it works. I see that if you want to go beyond what the original dimensions of the banner are all you have to do is make the CSS code height for the banner one less pixel. For e.g. If I want to do an image size of 1000x200px on the banner i would have to make the CSS code 1000x199px. I've tried it and it works. Great! I will email you my other issue that I have regarding the site which I did email Sanja about too.
Photo of Lorenzo Alberto Arteaga Avila

Lorenzo Alberto Arteaga Avila

  • 2 Posts
  • 0 Reply Likes
i have the same problem
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Lorenzo

Please let me know your URL and the name of the image file which you'd like to add to your banner area.
Photo of Jerry Hamilton

Jerry Hamilton

  • 2 Posts
  • 0 Reply Likes
I,m also having the same problem .......
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Can you let us know the website you are having the problem with?
Photo of Jerry Hamilton

Jerry Hamilton

  • 2 Posts
  • 0 Reply Likes
the website is: hamiltonwest.yolasite.com. The banner I have posted is the one I need to use. As you will see it has a white background and it should be transparent.
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Hello jerry,

I have been able to display your banner with a transparent background. I needed to do the transparency again as the editor loses the transparency specifically for the banner image.

The problem is that you can't use the banner placement facility to replace it as this will once again introduce the white solid background. You need to modify the CSS. I see that you have a free subdomain so may I ask what hosting subscription you are using/ (Free, Bronze etc). If you have subscribed to the free or Bronze Yola then this is a bit laborious and requires that you add the CSS to each page whereas if you have Silver or Gold then you can do this with Sitewide CSS.

Let me know and I can then follow up specifically. Happy to send you the redone image if you wish, by email.