banner/font issues

  • 1
  • Question
  • Updated 9 years ago
  • Answered
Whats happening to my banner, can someone tell me? http://food4memories.com/rice-with-ma...
the brown border with the website name has disappeared.
Also, why am I experiencing so much problem with font color when I apply links? I'm always having to fight and try to work around this problem. Thanks.
Photo of Rizan

Rizan

  • 219 Posts
  • 1 Reply Like

Posted 9 years ago

  • 1
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Hi Rizan

1. What exactly has been happening? Are you trying to upload a new banner and it won't work or is this already an existing banner and it's not doing what it's supposed to be doing?

2. Each template has its own default link color style. This is why you may be experiencing some difficulties. Are you wanting the links to be a particular color?
Photo of Rizan

Rizan

  • 219 Posts
  • 1 Reply Like
Hi littleus, when I change the banner picture I still retain the brown border and the name of the website, this is the first time that these have been
eliminated. Take a look at another page , this one shows correctly http://food4memories.com/bamya.php. I have not changed page styles.

As the font colors, yes I create my title, set up the font color and size. Then when I create the link it changes to blue and I have a heck of a time getting it back to green. Thanks.
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Rizan, the homepage banner is the one you made through Picnik, correct? If you're not going to use the homepage banner for each page, then you need to create a new banner using the new image you want for that particular page.

Now. onto your links. You don't want your links to change color at all when your mouse hovers over them?
Photo of Rizan

Rizan

  • 219 Posts
  • 1 Reply Like
thats odd littleus, I have been able to edit banner and insert other photos into banner without having this issue in the past. This is the first time I've had this glitch.
I would actually like the links to change color once someone opens a particular link. But, my real frustration is having the links change to blue after i've set them to green. Gets really annoying to have to fight with my font color everytime I create a link.
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Can you try to resize that particular photo on that page? Perhaps that's the cause of it taking so much room?

Which template are you using Rizan? I want to try to recreate your problem with the links. I tried it on my test page but my links were the same color.
Photo of Rizan

Rizan

  • 219 Posts
  • 1 Reply Like
Hi again littleus. I have changed photo size still no luck. Again, I have not had this problem in the past, I'm using the change banner photo function and up till now all has been fine. The template I use is called taste (or something or other) Brown banner with a lilly on the left.
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
That is very strange Rizan. Here's another suggestion. Try creating a new page and then copy the info from the old page to the new page, as well as doing your banner again. If that worked, then you can delete the old page and rename it the original name again.

It's getting very late here. I'll look into the links - I have not forgotten. I will get back to you tomorrow. Sorry that a resolution is long-coming.
Photo of Rizan

Rizan

  • 219 Posts
  • 1 Reply Like
:o) thanks as always lu! I will try creating a new page and see how that pans out!
Photo of Marije

Marije, Official Rep

  • 4636 Posts
  • 237 Reply Likes
Hi Rizan,

Just to let you know that we've received your email in Support (I'm sorry we didn't get to this thread earlier). Please let me know if you don't get the email as I've asked for more details from you.
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Hi Rizan

Okay.. I think I might have found a workaround for your links! I tried this out on my site and it seems to work. This might create just a tiny bit of work but hopefully it's a reasonable solution.

You need to drag an HTML widget over and place high up on your page. Paste this code in it (be sure to remove the <!-- & --> ).

<!--<style type="text/css"> a {text-decoration: none; font-family:Verdana; font-size: 10pt;} a:link {text-decoration: none; color: rgb(93, 196, 211);} a:hover {text-decoration: none; color: rgb(234, 99, 116);} </style>-->

For the a:link color, you put in the color of your existing color. This will make the link look like the same color as the rest of your text.

For the a:hover color, you put in the color you'd like to see when the mouse hovers over it.

That was the easy part. =)

Now for the bit of work. For all your existing pages, you will need to go into the HTML. You will see before your link text - <!--<a style=""color: rgb(0, 153, 0);" href="blah blah.com">--> You need to get rid of "style ="color:()" so that it looks like <!--<a href="blahblah.com">-->

For all your new pages, when you go to highlight your text color from black to the color you want, DON'T highlight the link text. The code above will change the link color. The original link color that came with the template will still show up in the builder. But, if you preview it or publish it, it will have the new link color.

The code above will apply to all your links on that page. So you don't have to keep adding this code to every link.

However, you will need to put that code on each page. If you have a different color text on that page, then simply change the a:link color.

I hope that makes sense.

2. I tried changing the banner and I come up with the same problem as you. The white background appears instead of the brown. It must be a bug. It's definitely not you! =)

Please let me know if you need further clarification. I apologize that it took so long to get this sorted out.
Photo of Rizan

Rizan

  • 219 Posts
  • 1 Reply Like
Hi LU, okay...this will take a lot of reading for me to understand lol. Just so I know, sorry the first part is for what and the 2nd part accomplishes what.....sorry, I'm really bad at this stuff!

Very strange, I show that boomer responded to this thread but, the response doesnt show here and on my email this is what shows up!

Boomer replied to banner/font issues, a question about Yola.
%3Cstyle%20type%3D%22text/css%22%3E%20a%20%7Btext-decoration%3A%20none%3B%20font-family%3AVerdana%3B%20font-size%3A%2010pt%3B%7D%20a%3Alink%20%7Btext-decoration%3A%20none%3B%20color%3A%20rgb%2893%2C%20196%2C%20211%29%3B%7D%20a%3Ahover%20%7Btext-decoration%3A%20none%3B%20color%3A%20rgb%28234%2C%2099%2C%20116%29%3B%7D%20%3C/style%3E

Way too strange!
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Hi Rizan! The first part is like a formula. It tells the page how to behave. Normally, that's all you need. However, since you added color to your text, this action has overridden the formula. This is where part 2 comes in. So for all previous pages, we have to undo that action specifically for the text link so that the formula will work and that you still retain the color for your non-linked text. For any new pages, it's a matter of remembering not to add any color to the text-link. Does this make sense or did I further confuse you? lol.

Very strange regarding Boomer's response. In the midst of all that gibberish, I think I can make out the same code that I gave you.
Photo of Boomer

Boomer, Champion

  • 2055 Posts
  • 84 Reply Likes
Sorry about that Rizan,

I was testing a new tool for posting code in GS.
I used a snippet of code that Littleus posted above for my test.
Here it is again. Hope it displays this time.

<style type="text/css"> a {text-decoration: none; font-family:Verdana; font-size: 10pt;} a:link {text-decoration: none; color: rgb(93, 196, 211);} a:hover {text-decoration: none; color: rgb(234, 99, 116);} </style>
Photo of Rizan

Rizan

  • 219 Posts
  • 1 Reply Like
Aargh.....why should font be sooo hard! We wouldnt it just work?
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Hi Rizan

I'm sorry that this is becoming such a chore for you. Can I do something to help? Do my directions need clarification?
Photo of Rizan

Rizan

  • 219 Posts
  • 1 Reply Like
lol thanks...wanna do it for me, kidding. No I'm just at a stand still at the moment due to the picture/banner thing as well! I am waiting for yola to get back to me on that issue. If I cant resolve it not really sure what route I will take, change format all together, something without a banner :o(
When my mind is clear I will print your instructions and try to follow, I'm scared that once I start fiddling around in there I might really screw things up then I'm up a creek. Thanks so much for all your help LU.
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
I understand your feelings of nervousness. I am like that too, especially after putting in so many hours of work. You'd hate to see one little misstep cause a whole lot of work go down the drain.

What I've learned to do when trying to fiddle with new codes, is to use the "save page as" function. This replicates your page entirely. Then, I try my codes on that page. If it doesn't work, then it's okay because you still have the original page. If it does work, then you can delete the original and then rename the second one the same name you had for the original page.

As for the banner...have you considered making a banner like you did for the homepage? If you go into Picnik, you'll see that they have various banner styles. Some with only two blocks, some with 3 and some with 4. You may be able to construct similar banners by using the 2-block one.
Photo of Monique

Monique, VP of Customer Support

  • 6294 Posts
  • 446 Reply Likes
Great tip. Thanks Littleus. We strongly recommend this approach when you are experimenting with code. It will save you a lot of grief! The more people who read this advice the better! :)