Cannot re-publish my site after updating it

  • 1
  • Problem
  • Updated 6 years ago
  • Solved
hi, i had been updating my unpublished sites for a few days now, during those days it was completely fine when i tried to publish it, however then i want to change my publish site name so i delete my website domain and tries to publish after i finish again. Since then i was not able to publish my website anymore as it stuck on the publishing site page for more than an 2 hours, please help asap!! I had not register a page after i delete my last one but it says my sites is not publish and had a yellow icon on the right.
Photo of Chris Cheng

Chris Cheng

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 6 years ago

  • 1
Photo of Gop


  • 7473 Posts
  • 2115 Reply Likes
Hello Chris,

Do you wish to publish to a domain you own?

Domain and site name are two different things. You site name is changed by selecting Site>Site Settings and at the top of the page you can then change the site name.

To change the domain name you must have purchase the domain already. You can do that through Yola or another registrar if you wish.

Then you go to your advanced settings and select the domain you wish to publish to.

Finally you select Publish on the sitebuilder and check that it will be published to the correct domain.
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Chris

The only website in your Yola account is up on my end:

Please let us know if you have any questions or problems.