Can't change colour of text in blog posts

  • 2
  • Problem
  • Updated 9 years ago
  • Acknowledged
When trying to chnage colour of text in blog posts it either doesn't change at all, or it changes the font type and size too.
Photo of dyfed

dyfed

  • 55 Posts
  • 0 Reply Likes
  • frustrated

Posted 9 years ago

  • 2
Photo of Marije

Marije, Official Rep

  • 4636 Posts
  • 237 Reply Likes
Hi Dyfed,

Could you post a link to the particular blog post that is having this problem?
Photo of dyfed

dyfed

  • 55 Posts
  • 0 Reply Likes
Photo of Marije

Marije, Official Rep

  • 4636 Posts
  • 237 Reply Likes
Thanks for posting the link.

The reason why you are having difficulty is because the text has been copied and pasted from MS Word. When you copy and paste rich text directly from MS Word (or another word processor) onto your site, this brings along a whole lot of unwanted formatting that is not web friendly and can easily break your page. It can also cause your site to show up inconsistently in different browsers. The problem might not always show up immediately, but sometimes it happens after you save and navigate to a different page or log out and log in again.

To avoid display and loading issues, the best alternative is first to paste your text into NotePad (in the accessories folder of your computer) and then paste it as plain text onto your Yola page. You can then use the Yola text editor to format your text as desired. Please note that this would be the case with any browser-based text editor you might use, not just Yola. It is a universal website building problem.

What you can do in this case:
1. Copy the text from the blogpost and paste it into Notepad.
2. In the blog post, click on the HTML button and select all of the text/code in the post and delete it.
3. Click the HTML button again so that you're back to the normal text editor.
4. Copy the text from Notepad and paste it into the blog post.

Will you let us know if this does not work for you?
Photo of dyfed

dyfed

  • 55 Posts
  • 0 Reply Likes
Really appreciate the prompt reply and help ... but the problem remains. I use Arial in MS Word - it copies as Arial into Yola text editor (from Notepad) but then changes to Times (?) when I try and change the colour of the text in the editor.
I also tried a new post - copy and paste from Word into Notepad then into editor and same thing happend. I haven't published that post on web though.
Photo of Emmy

Emmy

  • 5892 Posts
  • 299 Reply Likes
Hello dyfed,
Can you tell me if you tried a completely new blog post when you copy and pasted directly from Notepad? If you copied into a blog post that had previously had text copied from MS Word the formatting may have stayed in place. Can you please try using a fresh blog post, and then copy the text from Notepad into it.

Please let us know how this goes for you.

Emmy
Photo of dyfed

dyfed

  • 55 Posts
  • 0 Reply Likes
Hi Emmy,
Yes - I tried both ways - changing the original post and doing a new post. Same problems arose. It seemed that the format from Word had carried over into Notepad and then from NP into Yola editor. I expected to loose my formatting in NP - but it stayed.

Dyfed.
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Hello Dyfed

Emmy has asked me to look at your site. I believe I have fixed up the issues. Can you please take a look?

When you say you used "Notepad" - I'm wondering if you're using "WordPad"? If so, that will contain the rich text formatting.

Please let me know if you have any further questions.
Photo of dyfed

dyfed

  • 55 Posts
  • 0 Reply Likes
Hi Sanja,
Thanks for your input but - sorry - the problem remains. Annd I've definitely been using Notepad and not Wordpad. Again - I've tried to chnage the existing post and post a new one following the instructions above. This time there is no change in colour at all - but a change in font type from my orginal Arial to Times.

Sorry to be a pain!

Dyfed.
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Hi Dyfed

No apologies needed. I'm glad to hear that you are definitely using Notepad. Now.. can you try going into your "Edit HTML Code" icon on your blog toolbar? Delete the entire content.

Go back and copy the text from Notepad and then paste into your blog post.

Then, if you want to change the font of your blog post, this is what you need to do:

1. Click on the "Edit HTML Code" icon on the blog toolbar, it is the very last icon.

2. For the text you would like to change you can use this code. Where you see "courier", that is where you can put the font style you would like to use.

<span style="font-family: courier">This is the text you would like to change.</span>

Please note: Not all fonts are web safe, this means that some browsers will not be able to display certain fonts. If you look at the list of fonts that are available in the text widget, this is a list of fonts that are web safe.

Please let me know how this goes!
Photo of dyfed

dyfed

  • 55 Posts
  • 0 Reply Likes
Hi Sanja,
Ok - would i have to change the font in every line? It seems a lot to do for such a small change.
Anway, I posted a new entry this morning - typing straight into the editor and then put a link in (all fine so far) but then went to change the colour again - and not only did the colour change but also the font! I stress - I did not copy and paste from any other file.
It would seem that there is a problem with the editor - not just with pasting from Word.
Is it not possible to give us a font type option - as you have in a non-blog text box?

Dyfed.