cant upload photos into blog post

  • 1
  • Question
  • Updated 7 years ago
  • Answered
Hi i have put photos into my blog in the past using the add image tool.

Now i cant seem to be able to do it.

It will go all the way to select the image, but then instead of placing the image it places a little red square that then dissappears?

Help please
Photo of jodienosworthy

jodienosworthy

  • 4 Posts
  • 1 Reply Like
  • frustrated

Posted 7 years ago

  • 1
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Hi Jodie,

I suggest that you usea simple piece of HTML to add the images to your blog:
<img src="resources/image-name.jpg (png or gif)"; height="xxx px; alt="alt text;">

The dimension isn't important if you want to place the image at it's stored size and the alt text is an important but not obligatory comment on the image as a descriptive aid for SEO and visually impaired viewers who may be using a site reader.

if you would like any further help on this please ask.
Photo of jodienosworthy

jodienosworthy

  • 4 Posts
  • 1 Reply Like
Thank you for that... but I dont understand, I have never used a HTML before.

how do i found out the info of the image?

and will i have to do this for every image from now on?

I just didnt understand why the edit add image button worked on my first few blogs and then today it just stopped ?

I am using yola for my uni assignment and we have to have images in the blog so im a bit stressed at the moment
Photo of jodienosworthy

jodienosworthy

  • 4 Posts
  • 1 Reply Like
Thank you for that... but I dont understand, I have never used a HTML before.

how do i found out the info of the image?

and will i have to do this for every image from now on?

I just didnt understand why the edit add image button worked on my first few blogs and then today it just stopped ?

I am using yola for my uni assignment and we have to have images in the blog so im a bit stressed at the moment
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Hi Jodie,

Definitely not worthwhile getting stressed on this count and I empathise with the stress that deadlines can cause. Take it with slow deliberate steps and it will come out OK.

In your site builder on the blog page your need to add a new post if it in fact is a new post.

Click the HTML button on the far right in the tool bar and it will change colour to blue. This is where you add your HTML code.

So to explain the code a little. img src is a tag it directs the HTML that you are referring to an image and that image is in your File Manager. I'm presuming that you haven't created any folders within the File Manager. Tags always begin with < and after the content ends with >

"resources/....... > is simply the default name of the File Manager this is then followed by a / which is a separator so that the HTML knows that you are now making a second level of instruction. the following bit of code is the image name that you wish to use that is already stored in your File Manager with that exact image name.

As I mentioned the height and alt are not obligatory, so I think that at least for the moment you can leave them out. Then Hit enter. Save and Publish.

You should now be able to see your image in your live site. This may take a half minute or so to be seen live.

The code thus <img src="resources/image-name.jpg (png or gif)";>
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Hi Jodie,

I just tried the image widget in the blog and it seems to work using FireFox. I don't know if you are using this but it may be worth your while switching to this browser for this purpose?
Photo of jodienosworthy

jodienosworthy

  • 4 Posts
  • 1 Reply Like
Hi

I just uploaded fire fox and its now all working!!!!!!!

thank you! thank you! thank you!
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
That's a great relief Jodie,

Hopefully the story with other browsers will be worked out for yourself and others.