Charged twice and NO Domain!!! My payment did NOT fail!!!

  • 1
  • Question
  • Updated 9 years ago
  • Answered
I paid for my domain name through paypal, it said payment failed, so I tried again using my credit card. Again, payment failed. I then received 2 emails confirmed 2 payments for 19.95. My bank statement also shows 2 payments for 19.95. I was charged twice, and I have NO domain. This sucks
Photo of stella


  • 1 Post
  • 0 Reply Likes
  • pissed

Posted 9 years ago

  • 1
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Hi stella

Please email to give this information to them. I'm sure they'll be able to help you sort it out.
Photo of Peter


  • 2569 Posts
  • 113 Reply Likes
Hi stella,

I can only bet that your feeling really frustrated and annoyed. I'm sorry that this has happened to you.

This has to be the thing that accountants' book-keepers have nightmares over. It has to be a really unfortunate glitch and I'm sure that the Yola people will be disappointed to think that this has happened.

Currently it's about 5 in the morning in SA and I'm sure when they're onboard (early usually) they will address this very promptly.

Probably within a couple of hours this will be resolved.

Good luck stella.
Photo of Marije

Marije, Official Rep

  • 4636 Posts
  • 237 Reply Likes
Hi Stella - we've received your email in Support and I've answered. Everything has been resolved, your site is up and only payment has been captured.

Please come back to us if you have any further questions.