Css editor won't work after entering a code

  • 1
  • Problem
  • Updated 4 years ago
  • Solved
I was hoping to verify my domain so that I could register my domain for google apps and I followed the instructions, which said to post a html tag at the top of my code. I did so and checked the preview, which looked normal and I was excited. I hit submit and then noticed that all my text in the whole website has been replaced by an x for each text box. Buttons no longer work and I cannot edit the pages in sitebuilder. The pages still look and function the same in preview mode, but not in sitebuilder. I am afraid to publish, worried that once I do there's no going back. Help!

harmonystockton.org is my website.
Photo of Scott Thomas McColl

Scott Thomas McColl

  • 12 Posts
  • 0 Reply Likes
  • concerned

Posted 4 years ago

  • 1
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Hello Scott,

Adding the HTML tag isn't the way to verify your Yola site with Google. Have a look at the Yola Tutorial on this for specific information on setting it up with Yola. Setting up your email with Google Apps.
Photo of Scott Thomas McColl

Scott Thomas McColl

  • 12 Posts
  • 0 Reply Likes
Thanks, how do I undo the HTML tag I added?
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Are you seeing this in your CSS editor?
WARNING

We had to strip some HTML it found the last time you saved your CSS.

This may have changed your formatting.

To avoid unwanted formatting changes in the future please don't include any HTML in your CSS.

*/
Photo of Scott Thomas McColl

Scott Thomas McColl

  • 12 Posts
  • 0 Reply Likes
No, if I go to style then hit site CSS, absolutely nothing happens. If I go to site, content then site CSS it pops up a window but then the window closes. If I hit site tracking code from tracking, it says "this page at sitebuilder.Yola.com says 'Could not load the settings dialog. Please wait for the page to finish loading'" and no amount of waiting f really does anything. I hope I am not out of luck, I poured a lot of time into developing this site.
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
So you added it to the site tracking?

Header or Footer?
Photo of Scott Thomas McColl

Scott Thomas McColl

  • 12 Posts
  • 0 Reply Likes
Header I believe
Photo of Scott Thomas McColl

Scott Thomas McColl

  • 12 Posts
  • 0 Reply Likes
Also it should be worth noting that none of the widgets work. They highlight in the add widget bar but nothing happens when you click them.
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
OK. It sounds as if you have crashed your site. The header and footer sections are non-correcting and the code has to be complete and perfect.

We can hope that the engineers can recover this for you, but not guaranteed. Please send a message through the Customer Support facility and just reference this thread for their information.

Don't publish your page again as that may lock out any attempt to recover.
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
I've just looked at your site with Firebug and can see the issue I think.
In the head I can see: <meta content="!" name="fragment"> Which means that the code was incomplete and it's looking perpetually for the end of the code. That sounds promising as the potential solution is to remove the fragment. It is a job for the Yola people as it means getting access to the deeper parts of the site code content not able to be done in the user sitebuilder with the tools on hand.

If they are unable to do that then there is still a last ditch option which can be tried if all else fails.
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Scott,

I've solved the problem by removing the problematic javascript code from your Site CSS overrides. The Site CSS Editor can only be used for editing CSS code. For me your site seems to show correctly again.

If you'd like to add any code in future, I'd suggest to contact our support first to make sure that you add it to the right area of your website.

Please also consult our extensive Knowledge Base for getting the correct steps to add features like Google Webmaster, Google Analytics or Google Apps.

Let me know if your website shows as usual and you can edit it again.
Photo of Scott Thomas McColl

Scott Thomas McColl

  • 12 Posts
  • 0 Reply Likes
Thanks you!! I was shocked when I signed onto the website in the morning to find it working perfectly. You work fast!

Thank you again,
Scott