displaying alternate text when flash not available

  • 1
  • Problem
  • Updated 6 years ago
  • In Progress
Hi,

I have embedded flash to display animated text on my website.

I have tried many many suggestions on the net including the flashhtml site but I can't get it right.

The alternate text also displays not matter what I have done.

Below is the code, followed by the DiV tag I have used to try to display the alternate text:



I have tried inserting the DIV tag before the opening OBJECT tag and also where you currently see it.
I think I may be doing something fundamentally wrong with the placement and content of the DIV tag.

Also tried replacing the id="images/homeheader2.swf" with id="logo70644855.swf" but still displays both alternate text and cash animated text.

Any help much appreciated!!!!!!!!!!!!

Ciaran
Photo of ciaran

ciaran

  • 4 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 1
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Hello Ciaran,

Your code is not displaying. You can embed it following the forum requirements for displaying code; see the link (some HTML allowed) and look at the section on Code.

You can also embed flash movies using the Yola widget which is in the widget collection in your sitebuilder.
Photo of ciaran

ciaran

  • 4 Posts
  • 0 Reply Likes
Hi,
When I click the 'some HTML code allowed' it just refreshed this page?
Ta
Ciaran
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Oops. It was supposed to open the help file. No matter just look down to the beginning of the next reply box and you will see the help file by clicking on that.
Photo of ciaran

ciaran

  • 4 Posts
  • 0 Reply Likes
Ok, here goes:



<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"

class="result10435918"
codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,40,0"
width="595"
height="39"
id="haxe"
align="middle">
<param name="movie" value="logo70644855.swf"/>
<param name="allowScriptAccess" value="always" />
<param name="quality" value="high" />
<param name="wmode" value="transparent" />

<div> <p>text</p><embed src="images/homeheader2.swf"
wmode="transparent"
width="595"
height="39"
name="haxe"
quality="high"
allowScriptAccess="always"
type="application/x-shockwave-flash"
pluginspage="http://www.macromedia.com/go/getflashplayer"

></embed></div>
</pre>


Hopefully u can view this now:)
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Hi Ciaran,

Can do.

Are there 2 movies referred to in that code and the first .swf doesn't have an address?(It may well be that the lower part of the code is the text you are referring to?) Presumably it is also stored in your File Manager which always has resources as part of the path because resources is the default name for the File Manager. It would be something like ="resources/images/logo70644855.swf" and for the second .swf file it would be: "resources/images/homeheader2.swf". This is pointing to your .swf files if they are in a folder within your File Manager called images

I am not familiar with running two movies at once in the one code snippet as I have never come across this before.
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Ciaran,

if you are still hitting problems with this, you are welcome to email me the .swf file(s) and I can do a trial run on a test site. if I get it working I will let you know the trial site name by email plus the specific instructions . This is completely up to you.

My email address is: gop@designscent.com
Photo of ciaran

ciaran

  • 4 Posts
  • 0 Reply Likes
Sure that would be great.

I downloaded HTML code form a website where u design a animated text logo, which generates the the code and I embed it. I have change the file movie names to match but still have the same problem.

I have added the revised HTML, ill also email u the .swl files (much appreciated btw!!!)

Revised Code so .swf file names match:



<div id="images/homeheader2.swf">Alternate Text</div>
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"

class="result10435918"
codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,40,0"
width="595"
height="39"
id="haxe"
align="middle">
<param name="movie" value="images/homeheader2.swf"/>
<param name="allowScriptAccess" value="always" />
<param name="quality" value="high" />
<param name="wmode" value="transparent" />

<embed src="images/homeheader2.swf"
wmode="transparent"
width="595"
height="39"
name="haxe"
quality="high"
allowScriptAccess="always"
type="application/x-shockwave-flash"
pluginspage="http://www.macromedia.com/go/getflashplayer"

></embed>
</pre>

Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
I have your email Ciaran,

It's 07:45 am here and for you it may be middle of the night. Please don't hang around if you are simply waiting for this. I will email you the details of any success or otherwise. It may take a while before I can get this sorted or otherwise