DNS and subdomain error

  • 1
  • Question
  • Updated 9 years ago
  • Answered
Hello!

I made subdomain yesterday. And yesterday it worked fine. But today subdomain is not working anymore. I get an error message saying: DNS error - cannot find server. I've looked at Advanced Domain Settings - DNS Entries and everything seems fine.

When i try to publish my page it keeps publishing me to www.slo.gfoutsourcing.com. Yesterday this linked worked. But if I go now to slo.gfoutsourcing.com it is OK. OK no problem, but why Yola is reporting to me that site was published under www.slo.gfoutsourcing.com ?

Regards, Gregor
Photo of GF

GF

  • 2 Posts
  • 0 Reply Likes

Posted 9 years ago

  • 1
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
So what your saying is that once you publish the site in the publishing site window you get a link which reads like this:

Your site is publsihed on www.slo.gfoutsourcing.com

and if you click that link you (obviously) get a server not found error?

If the answer is yes it sounds like a bug - Yola staff will need to look at it.

Lee.
Photo of GF

GF

  • 2 Posts
  • 0 Reply Likes
Yes, but it is strange that yesterday domain worked under www.slo.gfoutsourcing.com but today it is only reachable through slo.gfoutsourcing.com. And yes in publishing site window I get wrong address then.
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
the slo. is replacing the www. like a CNAME.

It shouldnt be there and if the site builder is giving you an incorrect link in the publishing window its a bug which needs looking at.

I'm sure a staff memeber will read this a little later on this morning.

Lee.
Photo of Marije

Marije, Official Rep

  • 4636 Posts
  • 237 Reply Likes
Hi GF,

You'll see that this address works: http://slo.gfoutsourcing.com/, but not http://www.slo.gfoutsourcing.com/.

This is because you'll need to make sure that both are accounted for when creating your subdomain address.

Here's how:
1. In the first A Record, just add the name and paste the IP address in the Value field.
2. In the second A Record, add an "*.name" (where name is your subdomain name) under the name and paste the IP address in the Value field.

Here's a screenshot of what it should look like:


I hope that helps!