Do My Site Has Technical Fault?

  • 1
  • Question
  • Updated 5 years ago
  • Answered
Hi
I have site which is almost 2 years old, I uploaded the site and did not have look at it for a long time. When I came back to it , I noticed that the site is not available when searching in search engine. My point is that I searched using the "site:yourdomain.com" in search bar and i find every pages that is available on my site. But I cannot find it by searching with "yourdomain" in the search bar. I then added " yourdomain.com" also to search and still nothing useful happens. Is there anything missing in my site technically ?

I really need suggestions to find it. Thank you
Photo of praveen

praveen

  • 1 Post
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Hello Praveen,

Has your domain and or your Yola hosting expired in the meantime?

You may check this in your sitebuilder under account.
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello praveen

I'm happy to check your Yola account for you if you provide me your URL to find your account in our system. If you wouldn't like to share this information on our public Support Forum, please send your request using our Contact Support Form.

SEO is a big topic, and you can do a lot to keep performing well in search engines. We have quite a bit of a tutorial collection about SEO on our Support pages: Promotion, SEO, Traffic and Advertising. Have a look especially at SEO: Promoting your Site, and Why can't I google my site.