Domain publishing

  • 1
  • Question
  • Updated 3 years ago
  • Answered
Hi, I've just noticed a huge drop in my rankings on google so started trying to figure out why? So I noticed that when I publish my site it publishes to http://cmdceramics.com and not http://www.cmdceramics.com which is where all my links point to? Could this be the problem? I've also looked at my webmaster tools and it says that I have 0 pages indexed for one cmdceramics.com and that googlebot cannot crawl www.cmdceramics.com? Is it possible to change this to the www. Version on yola or is it something I need to do through my domain registrar which is domain monster? Thanks for your help
Photo of cmd ceramics

cmd ceramics

  • 87 Posts
  • 1 Reply Like
  • confused

Posted 3 years ago

  • 1
Photo of Peter Sauer

Peter Sauer

  • 150 Posts
  • 65 Reply Likes
My yola settings give the same response as yours does, have you set your google
Set your preferred domain (www or non-www) correctly.
Specify a preferred domain:
  1. On the Search Console Home page, click the site you want.
  2. Click the gear icon , and then click Site Settings.
  3. In the Preferred domain section, select the option you want.
here is a screen shot on how my page looks.
Hope this helps
Peter
Photo of Peter Sauer

Peter Sauer

  • 150 Posts
  • 65 Reply Likes
I just checked your indexed site pages in google and it shows 33 pages as being indexed
Photo of cmd ceramics

cmd ceramics

  • 87 Posts
  • 1 Reply Like
Hi Peter, thanks for your help, I just had a good look through my webmaster tools and noticed I've had a crawl error which I think would explain my drop in rankings. I just resubmitted for indexing and 10mins later everything seems to be ok.

Appreciate you taking the time to help. Many thanks!
Photo of Peter Sauer

Peter Sauer

  • 150 Posts
  • 65 Reply Likes
My pleasure
Photo of Peter Sauer

Peter Sauer

  • 150 Posts
  • 65 Reply Likes
Hi
Just looked at you site, could I make a suggestion, all your text is tight to the left hand side and makes it difficult to read.
If you go to Yola sitebuilder page > designer > content padding > set left and right padding to say 15px and save. currently your padding is set to zero
Hope this helps
Peter
Photo of Laura Thomas

Laura Thomas, Social Media Coordinator

  • 4536 Posts
  • 211 Reply Likes
I'd suggest choosing "rem" instead of "px" when setting your padding so that it's responsive on mobile devices but otherwise Peter's advice is spot on!