Don't know how to fix the issue with this Text Box Widget.

  • 1
  • Problem
  • Updated 7 years ago
  • Solved
Ok, so I have just added a text box widget on one of my pages. I saved, and then clicked Publish, but then when I visited my website on the internet, the text was center aligned, even though I never center aligned it. So I go back to the website editor, and go to the page that I want to edit the center aligned text on, but as I try to click the text box so I can edit the formatting, it doesn't let me edit.

It seems as if the text is stuck in the white background, and the text box widget has disappeared, and I can't edit it anymore.

Please help...

If the website URL is needed, here it is:
http://damianandchelseyforeverinlove....
Photo of damiantheman2

damiantheman2

  • 5 Posts
  • 0 Reply Likes
  • confused

Posted 7 years ago

  • 1
Photo of Nathan

Nathan, Champion

  • 3739 Posts
  • 307 Reply Likes
Hi damiantheman2,

It looks like you may have added some HTML code to your page that is making the text widget act like that. Can you post a screen shot of how the text widget looks in your site builder?

We look forward to getting this problem solved.

Kind regards,
Nathan
Photo of damiantheman2

damiantheman2

  • 5 Posts
  • 0 Reply Likes
Instead of a screenshot I have made a quick short video, presenting the problem in that way... I will be posting it in this topic within the next 5 minutes or so. Thank you for your quick response.
Photo of Nathan

Nathan, Champion

  • 3739 Posts
  • 307 Reply Likes
Okay, great. Looking forward to see that video of the problem.
Photo of damiantheman2

damiantheman2

  • 5 Posts
  • 0 Reply Likes
Alright, posted.
Photo of damiantheman2

damiantheman2

  • 5 Posts
  • 0 Reply Likes
Alright, here is the link to the video, took a little longer than 5 minutes due to YouTube's lengthy processing and uploading, as well as my Screen Recording program exporting processing :/

https://www.youtube.com/watch?v=qU3XfP...

Thank you for your time and patience.
Photo of Nathan

Nathan, Champion

  • 3739 Posts
  • 307 Reply Likes
Hi damiantheman2,

That video you posted really helped! :) Thanks for posting that.

Once you opened the code for the Slide widget, I saw the problem. (I'm glad you opened that up and scrolled through the whole code, if you didn't, this would take a while to solve.)

The problem is that there isn't an ending </div> tag in the Slide code which is causing the rest of the page to break. At the end of that whole code for the Slide widget, just add this:


</div>



That should fix that problem with the text widgets.

I hope this helps.

Kind regards,
Nathan
Photo of damiantheman2

damiantheman2

  • 5 Posts
  • 0 Reply Likes
Ah yes, thank you very much for that helpful response, I must have erased that tag while I was editing the HTML. Well, the problem is fixed now, and I will know how to fix it in the future as well.

Thank you for your time. I guess this is one of the reasons why Yola seems to be one of the top website builders, and I would know, I have gone through several.

Have a nice day!(:
Photo of Nathan

Nathan, Champion

  • 3739 Posts
  • 307 Reply Likes
No problem :) I've gone through many website builders too, and Yola is the best one. I've been with Yola for about 2 years now and I wont ever switch.

Have a good day to you as well.

Nathan