Don't understand why Yola doesn't have FTP:(

  • 3
  • Question
  • Updated 10 years ago
  • Answered
I am just so frustrated. I have seen site after site that has FTP capabilities so I can use my Dreamweaver files but Yola doesn't have it and I payed 20 dollars for my yola site for a year. I mean that is cheap, but how do these free sites have what Yola doesn't? I am heartbroken because I can't use my Dreamweaver here. FTP can't be that hard to have if all these free sites have it?? Can someone explain it to me? Maybe I would feel better about Yola if I understood this.

denise
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes

Posted 10 years ago

  • 3
Photo of Sanja

Sanja

  • 10698 Posts
  • 495 Reply Likes
Hey there... almost done!

At first it was not working, then I went to your website to see how you've entered your image file names for the main buttons on your site. Now I see you've used capitalization.

I managed to change the main button paths.. but I don't know how you done your hover images.

Can you please be sure to copy exactly how your put in your image name.

For example, with your main images..
Your image path is actually:
fromheretoeden.com/resources/Buttons/About Us.jpg (not fromheretoeden.com/resources/buttons/about us.jpg)

For next time, I would suggest that you make all your image filenames lowercase - it's easier to remember that way =)

If you would be so kind to put down the hover images url again, that would be mucho appreciado. =)
Photo of Sanja

Sanja

  • 10698 Posts
  • 495 Reply Likes
Are you sure the hover images are in your resources/Buttons/ folder? Or did you put them in a different folder? Also..after adding your hover images, did you by chance update your site? If not, can you please do that.. that may help as well.
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
Yes, they are right in with all buttons:) and ok on the update. Just republish right? Well, not republish but update, yes did that for sure:)
Photo of Sanja

Sanja

  • 10698 Posts
  • 495 Reply Likes
okay.. then can you try updating your site?
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
Wait, I think we've missed something. I did upload the images of the main buttons to the webpage, but, not the hover buttons because I did not know where to insert those? Youre going to kill me right, lolj!!!:(
Photo of Sanja

Sanja

  • 10698 Posts
  • 495 Reply Likes
No, it's okay Denise.. you don't need to actually put the hover images onto your webpage. It was me.. I made a little typo.. that's why they weren't showing up! =)

I'm in the midst of tweaking it right now... be a little longer than I thought. Sorry.
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
Don't you dare say you are sorry, LOL!! I can't tell you how much it means to have you help me. I do need to learn how to do this on my own, basically just get the code down right;) denise
Photo of Sanja

Sanja

  • 10698 Posts
  • 495 Reply Likes
Okay.. thanks for being so patient... I had to check something out.

Now... It works.. but the problem is because your two images are not similar in size, when you go to hover over them, it shakes.

I would recommend that you go back to that source where you made your main buttons and make a second set of buttons the same size, but use a different color and these will be your hover buttons.

Let me know how you feel about this.
Photo of Sanja

Sanja

  • 10698 Posts
  • 495 Reply Likes
Yep.. that's fine Denise. Same name would be great!
Photo of Sanja

Sanja

  • 10698 Posts
  • 495 Reply Likes
Yep.. that's fine Denise. Same name would be great!
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
Ok, doing it now;)
Photo of Sanja

Sanja

  • 10698 Posts
  • 495 Reply Likes
great.. let me know when you're done. =)
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
wow, that was crazy! I uploaded my new buttons but they kept showing in file manager as the same old buttons. I finally did an update and they changed to the new ones. So they are there, that is totally confusing. When you replace a file it should show without updating:(
Photo of Sanja

Sanja

  • 10698 Posts
  • 495 Reply Likes
Okay my friend.. here we go!

Step 1: Delete all your current buttons.

Step 2: Drag an HTML widget over and paste this code into it.

<SCRIPT LANGUAGE="JavaScript"> <!-- Begin loadImage1 = new Image(); loadImage1.src = "http://Fromheretoeden.com/resources/B... to home page.jpg"; staticImage1 = new Image(); staticImage1.src = "http://Fromheretoeden.com/resources/B... Green Home Button.jpg"; loadImage2 = new Image(); loadImage2.src = "http://Fromheretoeden.com/resources/B... what we are about.jpg"; staticImage2 = new Image(); staticImage2.src = "http://Fromheretoeden.com/resources/B... Us.jpg"; loadImage3 = new Image(); loadImage3.src = "http://Fromheretoeden.com/resources/B... to the Mall.jpg"; staticImage3 = new Image(); staticImage3.src = "http://Fromheretoeden.com/resources/B... Mall.jpg"; loadImage4 = new Image(); loadImage4.src = "http://Fromheretoeden.com/resources/B...; staticImage4 = new Image(); staticImage4.src = "http://Fromheretoeden.com/resources/B... button.jpg"; loadImage5 = new Image(); loadImage5.src = "http://Fromheretoeden.com/resources/B... Us.jpg"; staticImage5 = new Image(); staticImage5.src = "http://Fromheretoeden.com/resources/B... us button.jpg"; // End --> </script>

Step 3: Drag another HTML widget over and paste this code into it and place this HTML box underneath the first one.

<a href="http://yolacodes.yolasite.com&quot; onmouseover="image1.src=loadImage1.src;" onmouseout="image1.src=staticImage1.src;"> <img name="image1" src="http://Fromheretoeden.com/resources/B... Green Home Button.jpg" border=0></a><br><br> <a href="http://yolacodes.yolasite.com&quot; onmouseover="image2.src=loadImage2.src;" onmouseout="image2.src=staticImage2.src;"> <img name="image2" src="http://Fromheretoeden.com/resources/B... Us.jpg" border=0></a><br><br> <a href="http://yolacodes.yolasite.com&quot; onmouseover="image3.src=loadImage3.src;" onmouseout="image3.src=staticImage3.src;"> <img name="image3" src="http://Fromheretoeden.com/resources/B... Mall.jpg" border=0></a><br><br> <a href="http://yolacodes.yolasite.com&quot; onmouseover="image4.src=loadImage4.src;" onmouseout="image4.src=staticImage4.src;"> <img name="image4" src="http://Fromheretoeden.com/resources/B... button.jpg" border=0></a><br><br> <a href="http://yolacodes.yolasite.com&quot; onmouseover="image5.src=loadImage5.src;" onmouseout="image5.src=staticImage5.src;"> <img name="image5" src="http://Fromheretoeden.com/resources/B... us button.jpg" border=0></a>

Step 4: Change all the "yolacodes.yolasite.com" to your own page urls

Step 5: Do that "save page as" so that you don't have to keep pasting these codes again. Do this as many times as needed.

Step 6: Enjoy your new buttons! =)
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
oh my gosh, this is amazing. Did you have to type all that stuff!!!!!!!!!!!! Ok girl, I will give it a go, wish me luck, LOL!!! Thank you , no matter what happens, you are wonderful in helping me:) denise
Photo of Sanja

Sanja

  • 10698 Posts
  • 495 Reply Likes
Hey Denise

the page urls are generally the name you gave each page.

so... look on your edit menu list.. and you'll see the names of your pages.

add the page name to the end of your url.

For example: it would be http://fromheretoeden.com/YOUR PAGE NAME GOES HERE
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
something went wrong joy. Nothing shows in sitebuilder when I enter the codes, I did change all the yolasite code to fromheretoeden.com/index.com. I wonder if the should be .html?? I'll try it while I wait to hear from you. Also, I did an update after I did the save as for each of my 5 pages, and opened my site and no buttons at all?
Photo of Sanja

Sanja

  • 10698 Posts
  • 495 Reply Likes
did you include the http:// in front of your url? Also, try leaving your page name as index... not index.com - see if that makes any difference.
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
Yes, they are entered exactly as listed above. I went back and looked to to make sure they were pasted in right. I will copy and paste the new 2nd code with changes. I did not see anything I was to change in first code right?









Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
Ohhhhhhhh, LOL, ok, gotcha now:) So sorry;) back to work:)
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
Trying to enter in code so you can see it Joy, havin trouble with the forum??









Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
It won't paste in joy, Im sorry, but anyway, I entered it exactly as it appears in my list of webpages above k? denise
Photo of Sanja

Sanja

  • 10698 Posts
  • 495 Reply Likes
This is what I see in your page source:

Fromheretoeden.com/resources/B..."

That is not correct.

Also.. when you copy the code from here, try pasting into Notepad first and then paste into your HTML widget.
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
Ok, I didn't put in resources etc. I did it exactly as in the list above. That is right correct? Also, I did put the code into Word Pad first and saved as incase I needed to go back and redo. The new codes looks just like yours, only with http://fromheretoeden.com/index for example, Then I did a save as for each of the 5 pages. Should there be a www. in front of fromheretoeden? Maybe that is what's wrong? There was no www in front of the yolasite code so I did not add www to mine? denise
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
And I do have to have two boxes to put the codes in right. I mean both codes cannot be in the same widget. Also, you can't put two html widgets in the same column box(text box) right? I'll go look again. denise
Photo of Sanja

Sanja

  • 10698 Posts
  • 495 Reply Likes
Word pad has inherent formatting which can cause problems on your site. Please if possible, use Notepad.

Also... the code be exactly the same as mine - including the resources etc... The only thing that is different is the a href tag with the yolacode.yolasite.com address. You do not need to include the www.
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
No, when I drag the html widget over it automatically makes another box on sitebuilder.
Photo of Sanja

Sanja

  • 10698 Posts
  • 495 Reply Likes
If you do not have Notepad, then you need to make sure you save your code as a .txt file not .rtf file. Then, open up your saved document as .txt file and copy the codes again.
Photo of Sanja

Sanja

  • 10698 Posts
  • 495 Reply Likes
You can put HTML widget boxes in the same column.. I'll show you what it looks like on mine. Hold on a sec...
Photo of Sanja

Sanja

  • 10698 Posts
  • 495 Reply Likes
Here's the screenshot:



By the way.. if you want to see this in action on my testsite: http://littleustestsite.com/test
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
Says "Address Not Found" :(
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
I know about the boxes in the column, I have that right darlin. Ok, I am sorry, I used Wordpad and yes, I have notepad. Be back asap:)

Joy, the only place I see fromheretoeden.com/resources/ etc etc is in the part of your code you did not tell me to change? Does that need to be changed as well?

denise:)
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
Still no go Joy:(
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
Is there any way I can show you the codes I entered into the widget boxes now from Notepad?? If so, I could show you.
Photo of Sanja

Sanja

  • 10698 Posts
  • 495 Reply Likes
Go here to encode your code: http://forsite.synthasite.com/encoder...

Then copy and paste onto the forum.
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
I can't get to your testsite through the link, says address not available or something like that. So it's working on your test page obviously so what the heck is wrong with my page? Is there anyone that can go in and look at my code? I am just positive I copied it correctly and did it right:(

My screen show 2 empty boxes but the code is in them, I looked several times. How can I paste the code here joy??
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
my new code with my info?
Photo of Sanja

Sanja

  • 10698 Posts
  • 495 Reply Likes
yes... please do paste your new code with your info.
Photo of Sanja

Sanja

  • 10698 Posts
  • 495 Reply Likes
here's my site again.. see if you can get to it now:

http://littleustestsite.yolasite.com/...
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
Do you want to take a break Joy? Something is just not right in the code evidently but I don't see it:( I was not to make any changes to your first section of code right? Because I didn't, inserted exactly as you had it, then, is 2nd code, I entered the fromheretoeden.com/index, etc etc with other 4 pages names.
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
and with the http:// still there.
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
Joy, is the main code, the codes you first pasted in above right? Because I cannot paste my code in here. Why are you able to paste it in and I am not? I am wondering if there are extra characters in your code that should not be there. When people paste stuff in here, they usually put in things like before and after?? Is that our problem maybe?? denise
Photo of Sanja

Sanja

  • 10698 Posts
  • 495 Reply Likes
You're right.. no changes to the 1st box.. just the second box with the a href tags.

Can you see it on my site?
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
Yes I can, now if it would look like that on mine, lol!!
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
<a href="http://fromheretoeden.com/index&quot; onmouseover="image1.src=loadImage1.src;" onmouseout="image1.src=staticImage1.src;"> <img name="image1" src="http://Fromheretoeden.com/resources/B... Green Home Button.jpg" border=0></a><br><br> <a href="http://fromheretoeden.com/about-us&quot; onmouseover="image2.src=loadImage2.src;" onmouseout="image2.src=staticImage2.src;"> <img name="image2" src="http://Fromheretoeden.com/resources/B... Us.jpg" border=0></a><br><br> <a href="http://fromheretoeden.com/the-mall&quot; onmouseover="image3.src=loadImage3.src;" onmouseout="image3.src=staticImage3.src;"> <img name="image3" src="http://Fromheretoeden.com/resources/B... Mall.jpg" border=0></a><br><br> <a href="http://fromheretoeden.com/faqs&quot; onmouseover="image4.src=loadImage4.src;" onmouseout="image4.src=staticImage4.src;"> <img name="image4" src="http://Fromheretoeden.com/resources/B... button.jpg" border=0></a><br><br> <a href="http://http://fromheretoeden.com/cont...; onmouseover="image5.src=loadImage5.src;" onmouseout="image5.src=staticImage5.src;"> <img name="image5" src="http://Fromheretoeden.com/resources/B... us button.jpg" border=0></a>
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
Ok, hope I did that right, it looks the same so far, Im checking against my wordpad doc
Photo of Sanja

Sanja

  • 10698 Posts
  • 495 Reply Likes
There's a couple of things here...

Some of your site url has capital F - should all be lower case f in from

you have a double http:// for your contact- us - take one of those http: out

give that a go.. and let's hold our breath! =)
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
Ok, I will fix it:) Don't hold your breath I don't want you faintin, lol!!
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
<a href="http://fromheretoeden.com/index&quot; onmouseover="image1.src=loadImage1.src;" onmouseout="image1.src=staticImage1.src;"> <img name="image1" src="http://fromheretoeden.com/resources/B... Green Home Button.jpg" border=0></a><br><br> <a href="http://fromheretoeden.com/about-us&quot; onmouseover="image2.src=loadImage2.src;" onmouseout="image2.src=staticImage2.src;"> <img name="image2" src="http://fromheretoeden.com/resources/B... Us.jpg" border=0></a><br><br> <a href="http://fromheretoeden.com/the-mall&quot; onmouseover="image3.src=loadImage3.src;" onmouseout="image3.src=staticImage3.src;"> <img name="image3" src="http://fromheretoeden.com/resources/B... Mall.jpg" border=0></a><br><br> <a href="http://fromheretoeden.com/faqs&quot; onmouseover="image4.src=loadImage4.src;" onmouseout="image4.src=staticImage4.src;"> <img name="image4" src="http://fromheretoeden.com/resources/B... button.jpg" border=0></a><br><br> <a href="http://fromheretoeden.com/contact-us&...; onmouseover="image5.src=loadImage5.src;" onmouseout="image5.src=staticImage5.src;"> <img name="image5" src="http://fromheretoeden.com/resources/B... us button.jpg" border=0></a>

Ok, there is new encoded from synthasite. My page is still the same though after the changes Joy. I have to get ready for a birthday dinner and I am sure you are beat as well. Take a break girlfriend and now that I know where all the tutorials etc are in Yola, I can help myself a little better as well. Thanks so much for all your hard work. I will talk to you if you are here when I am finished with the dinner and cake, hugs, denise
Photo of Sanja

Sanja

  • 10698 Posts
  • 495 Reply Likes
Okay... I'm going to get you to go to the source and try it from there. Sometimes, codes are funny that way.. they only work directly from the source.

So.. go here: http://www.htmlbasix.com/mouseoverima...

Enter in all your information. Remember to be case sensitive as well.

Let me know how that works out!

Have a great birthday dinner.. and we'll talk again soon. =)
Photo of Sanja

Sanja

  • 10698 Posts
  • 495 Reply Likes
How did those buttons work out Denise?
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
hi darlin, I opted to use them just as clickable for now. Each takes me to the right page and later on, I will implement in new buttons with hover over:) Thank you for all the time you spent. I discovered the easiest way for me and settled for that:)

see you later, denise:)
Photo of Sanja

Sanja

  • 10698 Posts
  • 495 Reply Likes
I'm glad that you were able to find a workaround. =)
Photo of Denise

Denise

  • 393 Posts
  • 3 Reply Likes
thank you joy:) denise