Favicon works in FireFox but not Internet Explorer

  • 1
  • Question
  • Updated 8 years ago
  • Answered
Why does my favicon work in FireFox but not Internet Explorer?

By the way, the banner and logo was created by me... please tell me how it looks! :)

http://sitebuilder.yola.com/sites/D7d...
Photo of Donald

Donald

  • 2991 Posts
  • 37 Reply Likes
  • http://youcanneverbetoosmart.com

Posted 9 years ago

  • 1
Photo of Margie

Margie

  • 286 Posts
  • 25 Reply Likes
Take a look at Ed's (Honey Bear Playhomes) reply in this thread, http://forum.yola.com/yola/topics/why..., for a cross browser favicon.

I used it and it works in both.
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Great suggestion Margie!
Photo of Donald

Donald

  • 2991 Posts
  • 37 Reply Likes
yea, I suppose I can do that. It's so much easier to be able to upload a picture to the properties bar than having to locate the code for every page and placing the code in an html widget... that's such a pain, wish there's an easier way.
Photo of diane

diane

  • 1238 Posts
  • 121 Reply Likes
I only make an .ico file but do not add the code. Seems to work. Cuts down the time.
Photo of Margie

Margie

  • 286 Posts
  • 25 Reply Likes
Donald, like diane posted you make the .ico file and simply upload it to your File Manager, You don't need to add it to your pages. In fact, you want to be sure the favicon code box in Properties is empty on each page.
Photo of Donald

Donald

  • 2991 Posts
  • 37 Reply Likes
ok... how do I make the .ico?
Photo of diane

diane

  • 1238 Posts
  • 121 Reply Likes
Photo of David

David

  • 465 Posts
  • 94 Reply Likes
Hi
I have the same problem, I followed Margie's advice and created an ico file to upload, my problem is I can't delete the file in the favourites icon box as per the instructions, I can change the file but not delete it?
Any help would be appreciated
Photo of Nazlie

Nazlie

  • 1721 Posts
  • 51 Reply Likes
Hi David
Your .ico file should have been uploaded to your File Manager. If you have done so, then you will be able to delete it. Please see point 7 in this online tutorial: Using the File Manager.
Can you please describe where the favourites icon box is on your site?

Thanks
Nazlie
Photo of David

David

  • 465 Posts
  • 94 Reply Likes
Hi Nazlie
You misunderstand my question I don't want to delete the ico file I need to delete the favicon file as per Margie post
'In fact, you want to be sure the favicon code box in Properties is empty on each page.'
This is the file which won't allow me to delete it
Photo of Jean

Jean

  • 134 Posts
  • 14 Reply Likes
David, highlight the text in the favicon code box in Properties, hit Delete and save the page. It should now be gone.

(margie, in another life)
Photo of diane

diane

  • 1238 Posts
  • 121 Reply Likes
Hi, David,

Please let us know if Jean's advice doesn't work. (but it should).
Photo of David

David

  • 465 Posts
  • 94 Reply Likes
Hi
I obviously tried highlight, delete cursor, back button it won't delete.
Photo of Marije

Marije, Official Rep

  • 4636 Posts
  • 237 Reply Likes
Hello David,

Could you post your site's URL as well us let us know which page the favicon is on?

Could you also let us know which browser you are using (eg. Firefox 3, IE8 etc).
Photo of David

David

  • 465 Posts
  • 94 Reply Likes
Hi Marije
This is the site http://www.leathersolutions.org/ the favicon is on every page and I use Firefox 3 but have IE8 installed to check edits.
Photo of Marije

Marije, Official Rep

  • 4636 Posts
  • 237 Reply Likes
Thank you David,

I've had a look (using Firefox) and these are the steps that will work:
1. Open your site in the Sitebuilder and click on the Properties tab.
2. Click on the button next to the Favorites Icon - the File Manager will open.
3. Click on "None" on the bottom right.
4. Save and republish your site.

It will work in Firefox (I've tested to double-check). If it's not working in IE8, I'd definitely like to know.
Photo of David

David

  • 465 Posts
  • 94 Reply Likes
Thanks Marije I've now deleted the file and uploaded the ico file, both Firefox and IE are showing their default favicon at present,I guess I need to wait until the new favicon is picked up by both browsers?
Photo of Marije

Marije, Official Rep

  • 4636 Posts
  • 237 Reply Likes
Hi David - the file has been removed but you would need to re-add the .ico file in order for it to display. At the moment, it is set to display nothing because no file has been selected. Unless it's on a page other than the index page?
Photo of David

David

  • 465 Posts
  • 94 Reply Likes
Marije
I must have had a dumb moment because I completely forgot to add the new file.
The favicon is now showing in both browsers, thanks for your help
Photo of Marije

Marije, Official Rep

  • 4636 Posts
  • 237 Reply Likes
Glad to hear it's all good!