file link won't work

  • 2
  • Question
  • Updated 10 years ago
  • Answered
I can't upload a word file I've done it before but it won't create a link I post story's I write on my site but they won't open when I click on them
Photo of darkhearted

darkhearted

  • 1 Post
  • 0 Reply Likes
  • sad some of my friends live in other countreys

Posted 10 years ago

  • 2
Photo of Marije

Marije, Official Rep

  • 4636 Posts
  • 237 Reply Likes
Hi darkhearted,

I have given the steps below to adding a file using the File widget or linking to the file in a text widget:-

Here are the steps to adding the file with the file widget:
1. Drag and drop a file widget onto your page from the sidebar on the right (the icon for this looks like a computer disk)
2. Browse your desktop for a file to upload
3. When you click "ok" a link to your file will automatically be created. To text that it is working, save and preview your page.

Here are the steps to adding a link to your file in a text widget (you would need to upload your file using the File Manager first):
1. Drag and drop a text widget onto your page.
2. In the text widget type the words that you want people to click on (this is your link text)
3. Highlight the link text and then click on the link button (it looks like the link in a chain)
4. A link editor dialogue box will open up and you will be given 4 options.
5. Click on the 4th option - link to a file
6. You will then have a link on your page. To check that your link is working preview your page and then click on the link.

I hope that helps - you're welcome to post your URL here so that we can try it out!
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Hello Michael,

Thanks for that screencast. I just tried to get into your site and I was able to do this successfully using Google Chrome. I'm wondering if perhaps you might have security programs running? Can you try disabling Firewall, anti-virus, ad-blocker, spam blocker, pop-up blocker, etc?

Please let us know how this goes!
Photo of Michael

Michael

  • 27 Posts
  • 1 Reply Like
It works on Google Chrome as you said. Nothing has changed on my computers (two) since last time I did this. So not sure why it would work with Chrome but not Firefox or IE.
Photo of Nazlie

Nazlie

  • 1721 Posts
  • 51 Reply Likes
It could be dependent on the version of the browser(s). Which versions of Firefox and IE are you using?
Photo of Michael

Michael

  • 27 Posts
  • 1 Reply Like
Firefox 8. IE 9.0.8112
Photo of Brianna

Brianna

  • 2045 Posts
  • 92 Reply Likes
Michael,

We do know that IE9 is not that stable with it's compatibility with the sitebuilder. Please could you try to downgrade to IE7 or IE8 and let us know how that works?

As for Firefox, we currently support up to FF3.6.
Photo of caddy1949

caddy1949

  • 2 Posts
  • 0 Reply Likes
Do a restore.