Firefox add-on, No Script interferes w/ website editor

  • 1
  • Idea
  • Updated 9 years ago
  • Under Consideration
the popular firefox addon called noscript causes the website editor to have missing buttons. i know it's noscript causing the problem because when i disable it, the site editor is completely fine. also, just to let u know, i've allowed all scripts for yola.com.
Photo of keizou

keizou

  • 3 Posts
  • 0 Reply Likes

Posted 9 years ago

  • 1
Photo of KanThaiDecor

KanThaiDecor

  • 2402 Posts
  • 263 Reply Likes
Good to know...some may have had this problem not figured it out....@Yola staff...Since Firefox is the recommended browser for site building a list of possible conflicts with site builder and add ons could be started....Something that any of us site builders could add to if we run across a problem/solution as keizou did.
Photo of keizou

keizou

  • 3 Posts
  • 0 Reply Likes
anyone know how to fix the issue without diabling noscript?
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
i have never used it - so this is a guess - do they not have some kind of 'safe' list where you can add sites you trust?

Worth a look - alot of these kind of programs have something like this.

Lee.
Photo of KanThaiDecor

KanThaiDecor

  • 2402 Posts
  • 263 Reply Likes
This is right off the download page.....
The best security you can get in a web browser!
Allow active content to run only from sites you trust, and protect yourself against XSS and Clickjacking attacks.

So there is a safe list option it seems
Photo of keizou

keizou

  • 3 Posts
  • 0 Reply Likes
yola is currently on my safe list for No Script, but the buttons are still missing from the site editor
Photo of Monique

Monique, VP of Customer Support

  • 6294 Posts
  • 446 Reply Likes
Hi Keizou

Thanks for reporting this. I am going to install this plugin and see what I can find. If there is a bug I will report it.
Photo of Monique

Monique, VP of Customer Support

  • 6294 Posts
  • 446 Reply Likes
Well I installed NoScript and it seriously messed with all the websites I use. Not just Yola. Hardly surprising as it blocks Java, Javascript and Flash.

I tried to add the sitebuilder URL (the one you see in the browser window when you are in the sitebuilder) to the safe list, but the "Allow" button remained greyed out.

Keizou, can you try the following:
1) Log into Yola and open a site.
2) Copy the URL from your browser window and try to add that to your "safe" settings for NoScript.

I tried, but no luck - NoScript would not accept the URL. See if you can do it.

If not, it is a limitation of the addon and not something we can do much about.
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
Hi Monique,

It sounds like a bug at their end.

Did you try to add the URL with a open directory at the end?
http://sitebuilder.yola.com/
or maybe
http://sitebuilder.yola.com/ide/

rather than just
http://sitebuilder.yola.com
Photo of Monique

Monique, VP of Customer Support

  • 6294 Posts
  • 446 Reply Likes
All of the above :) No luck on any of them.