Forms not submitting from my site

  • 1
  • Problem
  • Updated 6 years ago
  • Solved
I reported this problem last night but now can't find my post, so trying again. A client submitted a form via my site which I didn't receive, and then I tried a test submission myself which I didn't receive either. Does Yola have a current bug that needs fixing, or is there something I need to do?
Photo of MillyMollyMandyB

MillyMollyMandyB

  • 14 Posts
  • 1 Reply Like

Posted 6 years ago

  • 1
Photo of Nazlie

Nazlie

  • 1721 Posts
  • 51 Reply Likes
Hi MillyMollyMandyB

Yola is not currently experiencing a bug related to Yola Form submissions. However, we have received reports that forms are not being sent to addresses that end in btinternet.com.

If you do not have a btinternet.com email address and are not receiving the emails from the form, please make sure that you are checking the correct email mailbox to which the forms are being submitted. The forms are submitted to your Yola login email by default unless you have changed it.

To check the email address, follow these steps:

  1. Click on "Edit" in the Yola Form Widget.

  2. In the Yola Form screen, click on the "Settings" tab.

  3. The email address where the form submissions are being sent, will be displayed here.

  4. If you have changed the email address, remember to republish your website so that the updated email address is live on the online version of your site.



If the email address is correct, please check the spam or junk mail folders to see if the form submissions have been delivered there instead of the inbox folder.

If you continue to have problems with form submissions, please share your website address and tell us which page your form is on. We will then be able to investigate it in more detail.

Nazlie
Photo of MillyMollyMandyB

MillyMollyMandyB

  • 14 Posts
  • 1 Reply Like
Thanks for your reply, Nazlie.

I have already changed the default email address for forms to mandy@amethystresearch.co.uk and I have received submitted forms to that email address.

There is nothing at all in my spam/junk folders.

I still haven't received the client form that was submitted on Saturday evening, nor the test submission that I tried myself.

This is the link to my form submission page: http://www.amethystresearch.co.uk/for...
Photo of Nazlie

Nazlie

  • 1721 Posts
  • 51 Reply Likes
Thank you for this update, MillyMollyMandyB. Did you change the email address before or after the emails were submitted?
Photo of MillyMollyMandyB

MillyMollyMandyB

  • 14 Posts
  • 1 Reply Like
I changed the email address before the forms were submitted - I actually changed it some weeks ago and have already received form submissions to the 'amethyst research' email address.
Photo of Nazlie

Nazlie

  • 1721 Posts
  • 51 Reply Likes
It looks like you have a large number of fields on that form, which could be the reason you are having not receiving the email submission.

I would suggest that you create a test page on your website with a shorter form, maybe half the length of the existing one, to see if that will work. If it does, then try creating a shorter form on your Form page.

Let us know if you need more help.
Photo of MillyMollyMandyB

MillyMollyMandyB

  • 14 Posts
  • 1 Reply Like
I've just sorted out the problem! I found the missing forms in my BTInternet spam folder but couldn't understand why they'd gone to that email address when I've already had forms to the Amethyst Research address.

I had only edited the email address in the first form, thinking it was for the whole page, and hadn't changed the default for the second and third forms.

Thanks for your help and apologies for taking up your time.
Photo of Laura Thomas

Laura Thomas, Social Media Coordinator

  • 4536 Posts
  • 211 Reply Likes
Glad to hear you were able to recover them!
Photo of Thomas Oliver Moyes

Thomas Oliver Moyes

  • 13 Posts
  • 0 Reply Likes
URGENT: I think I am now having the same problem, checking on my campaign with google today, I have had 2 conversions on google via this page: www.thesolarpanelgroup.co.uk/britishg... When the form is submitted it redirects to my info pack request submitted page and records the conversion, I have had 2 conversions today but have NOT received the forms (but I have received submissions from this page before it's a new problem today) I have just put a test submission through and that hasn't showed up either.

I have checked the e-mail address, it's correct, checked spam folders nothing there...if those two leads are lost that will cost me £130+VAT so please sort this out asap otherwise I will have to use a different service (even though yola is great so far).

Is there any way of getting them back through yola if they are lost?
Photo of Thomas Oliver Moyes

Thomas Oliver Moyes

  • 13 Posts
  • 0 Reply Likes
I have entered a test submission on other pages and still no e-mails there either...I need this sorted out as soon as possible please otherwise I will miss deadlines and lose £65+VAT for every lead that I don't receive which wouldn't be fun!.

Otherwise can you assure me that the leads are not 'lost' and are backed up somewhere?
Photo of Laura Thomas

Laura Thomas, Social Media Coordinator

  • 4536 Posts
  • 211 Reply Likes
Hi Thomas,

While investigating your problem we noticed that in your form settings you have added a meta tag in the completion message box. This field is designed to send a message to your site visitor that says something along the lines of, "we've received your submission and will be in touch."

We believe this could be interfering with your form submission. Please try removing that meta tag and re-testing your form.

Unfortunately if your form was never submitted successfully there will be no record of it.

Please let us know how removing the meta tag goes for you.
Photo of Thomas Oliver Moyes

Thomas Oliver Moyes

  • 13 Posts
  • 0 Reply Likes
Hi Laura,

This doesn't help at all, the meta tag is a redirect to my request submitted page so I can record conversions, like I mentioned above I have been receiving submissions from my forms without any problems until yesterday. I made no changes to them or anything, it just started happening?

The form must have been submitted successfully because Google recorded the conversions and they can only get to that page by submitting a form.
Photo of Thomas Oliver Moyes

Thomas Oliver Moyes

  • 13 Posts
  • 0 Reply Likes
I have just removed the meta tag and submitted a test, that didn't work. Does Yola keep a back up of the form submissions? or are those I received yesterday lost? the form was submitted successfully because it redirected to my redirect page?
Photo of Laura Thomas

Laura Thomas, Social Media Coordinator

  • 4536 Posts
  • 211 Reply Likes
Hi Thomas,

I'm very sorry to say that we do not capture any data from sent forms so if they are not in your email they cannot be recovered. Have you tried changing the email address associated with your form and sending a test message? We are currently addressing an issue with forms being received to @hotmail addresses. I wish I had better news for you.
Photo of Thomas Oliver Moyes

Thomas Oliver Moyes

  • 13 Posts
  • 0 Reply Likes
Hi Laura,

I'm now sending all the forms to my btconnect.com e-mail address and its working fine, the yola forms just don't send to any of my windows live (hotmail) addresses even the ones I have set up through hotmail as @thesolarpanelgroup.co.uk so it does seem to be a problem with windows live/hotmail.

If you could let me know when the problem is fixed that would be great as I have forms sending to different @thesolarpanelgroup.co.uk e-mail addresses and it is then automatically forwarded my customers. At the moment I have to do all this manually so it's quite annoying.

I'm guessing the Wufoo forms are all backed up? I may just switch to those forms at a later date.
Photo of Laura Thomas

Laura Thomas, Social Media Coordinator

  • 4536 Posts
  • 211 Reply Likes
Hi Thomas,

We will be sure to follow up here once we have a solution for WindowsLive rejecting form submissions.

You will need to touch base with WuFoo about their backup policy. I would suspect there may be privacy concerns at play but I'm really not up to speed on their offering.
Photo of seth kazzim

seth kazzim

  • 15 Posts
  • 0 Reply Likes
What about @yahoo.co.UK addresses?

I'm going to try .com

Does the length of the form matter?
Photo of Laura Thomas

Laura Thomas, Social Media Coordinator

  • 4536 Posts
  • 211 Reply Likes
Hi Seth,

I just replied to you in this thread. I'll continue to work with you there.