How can I specify the language of my website for search engines?

  • 1
  • Question
  • Updated 6 years ago
  • Answered

On I get the following message:

"You have not specified the language of your website. Use the META Language Tag to specify the natural language of your website."

How can I do that?

Thanks in advance.
Best regards
Photo of Francesco Patane'

Francesco Patane'

  • 50 Posts
  • 5 Reply Likes

Posted 7 years ago

  • 1
Photo of Nazlie


  • 1721 Posts
  • 51 Reply Likes
Hello Francesco

Thank you for asking this question. There is not currently the option to add the website language in the Yola meta tags configuration fields.

However, we may be able to help you with this problem. Please send an email to with the details of your website and meta tag request and we will get back to as soon as possible.

Thank you
Photo of Imi Parking

Imi Parking

  • 26 Posts
  • 0 Reply Likes
Did anything ever get sorted for this as I was going to ask the same question. I have 3 websites through Yola and the same thing is coming up for all of them.
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Imi Parking

Yes, let me be bold and say that everything gets sorted with Yola! :-)

We are constantly improving Yola, so we have also created a more convenient solution for this. You can now set up your site language easily by following these steps:
  1. Open your website in the Sitebuilder.

  2. Click on Site > Site Settings.

  3. In the Site Properties area, click on Language.

  4. Select your language.

  5. Click on All settings to go back and save the changes.

  6. Republish your site by clicking on the green Publish to the web button.

Please let me know if you still get those messages afterwards.
Photo of Imi Parking

Imi Parking

  • 26 Posts
  • 0 Reply Likes
I knew you would have the answer, that is why I am here.

Now if you can just tell me how to get to page 1 in a week I will be extremely happy..........joking

Thanks for that
Photo of Imi Parking

Imi Parking

  • 26 Posts
  • 0 Reply Likes
Hmm my site was already set to English but is not being picked up. Any ideas?