I can't publish the domain I own

  • 1
  • Question
  • Updated 8 years ago
  • Answered
I am unable to publish my website: www.kobrinassociates.com, which I own. When I try to publish it, it forces me to use www.kobrinassociatesgmbh.com. As I own kobrinassociates.com, why it does not let me publish it? My mail is isaac@kobrinassociates.com. Thanks, Isaac
Photo of Itzik


  • 1 Post
  • 0 Reply Likes
  • sad

Posted 8 years ago

  • 1
Photo of Gop


  • 7473 Posts
  • 2115 Reply Likes
Hello Itzik,

I can see that your domain is correctly pointed to Yolas servers so that is good to know.

I have taken an excerpt from a Yola tutorial about publishing to a domain that you already own and hope that this will help you publish your site:

  1. Click the green "Publish to the web" button in Yola.

  2. In the "Already own a domain?" section, click on "Point your domain now".

  3. Enter your domain name. If the domain is correctly set up, it will say "Congratulations. Your domain is pointed!". If your domain is not correctly configured, it will say "Sorry. This domain is not pointed correctly". You will need to go back to your domain registrar and double-check your settings.

  4. Click on the "Next" button to publish your domain.

    To publish your live site to your domain:
    If your site is already published to a Yola subdomain, go to My Yola.

  1. Click on "Domains".

  2. Under "Add a domain you already own" select "Want to keep your domain registered with another registrar?"

  3. Type your domain name into the required field, and select the site you'd like to use it with.

  4. Click "Add".

  5. Follow steps provided.

Photo of Laura Thomas

Laura Thomas

  • 4536 Posts
  • 211 Reply Likes
Hi Itzik,

Gop has given you the correct steps, but looking at your account, I see you are a YolaFree member. In order to publish to a custom domain we now require a hosting package such as Yola Bronze or Yola Silver.

Once you upgrade to a hosting package, the steps Gop provided will allow you to publish to your custom domain.