Links are wrong when typing it into a text widget.

  • 1
  • Problem
  • Updated 9 years ago
  • Solved
On the "no frills" template and possibly all of them... if you type in a website into a text widget starting with http ... it will automatically create a web address with the http and the first letter of the website for example if I typed, http: // youcanneverbetoosmart.synthasite .com (no spaces) the sitebuilder will create a link to http: // y ... just figured I would report this problem.
Photo of Donald

Donald

  • 2991 Posts
  • 37 Reply Likes
  • http://youcanneverbetoosmart.synthasite.com

Posted 9 years ago

  • 1
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
It does not do it in clean slate. And did not do it when i tested it in No Frills.

Are you sure you didnt highlight some text which you had applied a link to then type over the top of it?

Sometimes the code underneath remains in these situations.

Lee.
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
test it again with a new text widget.
Photo of Donald

Donald

  • 2991 Posts
  • 37 Reply Likes
no... and I'm not talking about opening the link editor either, I'm talking about typing the link DIRECTLY into the text widget without opening the link editor. If you didn't try that, I would try that way. And just to clerify, this is a new site with NO MS Word formatting so that's not the problem.
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
I understand that but it doesnt do it for me.

If you test it on a fresh text widget does it still do it?
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
Photo of Emmy

Emmy

  • 5892 Posts
  • 299 Reply Likes
Hi Donald,

I have just tested this and do not get the same results as you. Using the No Frills style I typed in http://yola.com and it appeared on the page the same way.



Emmy
Photo of Donald

Donald

  • 2991 Posts
  • 37 Reply Likes
ok.... instead of a screenshot, I figured I would save the page and give the preview link.... http://sitebuilder.yola.com/sites/S3/...
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Unfortunately, your link does not work. Can you try reposting the link again?
Photo of Donald

Donald

  • 2991 Posts
  • 37 Reply Likes
lol, actually I took it off of there when I didn't get any responses for a while... I just republished that for you. if your browser underlines links you'll notice that the whole link is not underlined, if you click on the "http://y" you'll notice that it'll take you to http://y which is an invalid address. Apparently it happens only to me, just keep in mind, there is no MS Word code on this site whatsoever. It's all been edited through the sitebuilder... in this particular problem, it underlines the "http://y" as I am typing the "whole" address...

http://printerfriendly.yolasite.com/t...
Photo of Marije

Marije, Official Rep

  • 4636 Posts
  • 237 Reply Likes
Hey Donald,

I think everyone couldn't replicate your point because we all use Firefox. This does happen when I'm in Internet Explorer 7.

But, when I type the whole link into the text widget, and then click out, the whole link is underlined - not a section of it like yours.

Are you using IE7 or IE8?
Photo of Donald

Donald

  • 2991 Posts
  • 37 Reply Likes
I am using IE8 but it's not just a matter of the underline, YOLA is actually (from the html) creating a link out of the first five letters "http://y" instead of the whole link. If you click on the http you'll see what I mean.
Photo of Marije

Marije, Official Rep

  • 4636 Posts
  • 237 Reply Likes
Hi Donald,

I see what you mean, and when I type in the URL in IE7, it underlines the whole URL and not just the first part. Could you confirm:
- what browser and version you are using
- when you are typing the URL, do you click out of the text widget, click back in again and continue typing the the URL?

If you would like a way to remove this link while we find out why this is happening, follow these steps:
1. Highlight the link
2. Click on the link editor in the text toolbar
3. Select "none" in the dialog box that opens
Photo of Donald

Donald

  • 2991 Posts
  • 37 Reply Likes
I am using IE8 and no, it underlines the way it does AS I AM TYPING the URL, I do not click out of the text widget and back in. I really don't see how a different browser could change the way Yola creates html.
Photo of Emmy

Emmy

  • 5892 Posts
  • 299 Reply Likes
Hi Donald,
I do see in the code that the link is create for only a small part of what you have highlighted. I don't have access to IE8 so will need to wait to test this until Monday in that browser.

Are you able to go into the HTML of the text widget and change the link code manually?

This is what the first link looks like in the code right now:

<!--
<A href="http://y">http://y&lt;/A>oucanneverbe...
-->

Can you change it to be:

<!--
<A href="http://youcanneverbetoosmart.synthasi... Text</A>
-->

I will look into it on Monday with IE8.
Photo of Donald

Donald

  • 2991 Posts
  • 37 Reply Likes
yes, I am able to change it manually, I can also use the link editor. Just for this specific task instead of using "words" as links I am using the actual link bc these will be printed out. It's better to just be able to type the link and have it linked appropriately than having to add an extra task. Especially with as many steps I have to take just to get one article on there. The average article takes me 30 minutes to 3 hours of constant work just to get it done... minimizing steps is important.
Photo of Emmy

Emmy

  • 5892 Posts
  • 299 Reply Likes
That is completely understandable and I will be looking into this on Monday when I have access to IE8 for testing. I appreciate your patience.
Photo of Emmy

Emmy

  • 5892 Posts
  • 299 Reply Likes
Hi Donald,
I am definitely seeing what you are seeing in IE8 and have logged this as a bug. I will post back here when there is a fix in place.

Thanks,
Emmy
Photo of Emmy

Emmy

  • 5892 Posts
  • 299 Reply Likes
Hello Donald,

I'm happy to report that this bug has been fixed! You won't be seeing the problem of only part of a link being hyperlinked any longer.

Emmy
Photo of Donald

Donald

  • 2991 Posts
  • 37 Reply Likes
So then I'm guessing yola has actually witnessed the problem? I thought I was going insane when not many people had this problem.