Links with unconventional TLD don't function correctly

  • 1
  • Problem
  • Updated 6 years ago
  • Solved
Recently had to add a link for an Australian sporting club that has a domain ending in .asn.au
Any attempt to add .asn.au using the toolbar resulted in a non-functioning link.

The work around was to convert the real link to a .COM alias using a link shortening service (eg: TinyURL)
Photo of Caniluna

Caniluna

  • 6 Posts
  • 0 Reply Likes
  • ok ...puzzle solved

Posted 6 years ago

  • 1
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Caniluna

That's an interesting problem – would you mind posting the complete link ending in .asn.au here for us to replicate? Thanks!
Photo of Caniluna

Caniluna

  • 6 Posts
  • 0 Reply Likes
ASN's are usually Australian Sporting clubs.
The one I was working with was:
http://www.slst.asn.au

There is some background on .asn.au at:
http://www.ausregistry.com.au/asn.php
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Hi Caniluna,

A very impressive catch and work around.
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Caniluna

I cannot confirm that the URL http://www.slst.asn.au/ would not work as a link added to a Yola website. I successfully added it to text in a Text Widget: http://justfortesting.yolasite.com/

There is no restriction on URLs to be linked on a Yola website. The main thing is that they are a valid link linking to an existing destination.

If this problem is specific to your account, please post your URL here for me to find your account and check it. Thanks!
Photo of Caniluna

Caniluna

  • 6 Posts
  • 0 Reply Likes
The problem wasn't so much that the link couldn't be added, but that it was non-functional. (Nothing between the anchor tags)
That didn't become obvious until the page was published.

The current published version has the workaround in place.
http://www.penguinfestival.com
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hi Caniluna

Do you mean that after you had added the link to a Text Widget, the link wasn't shown in the <a> tag in the HTML code of this Text Widget? In my test version I can see the link added to the <a> tag, so I don't need any workaround.

If you'd like to, let me know if I'm not getting you right and explain it to me again. Thanks.
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Oh well the romance of the solution is debunked but I really like the brilliant idea of using a shortner to add to the link and subs a .com name domain :)