Menu drop down background color

  • 1
  • Question
  • Updated 10 years ago
  • Answered
Hi All
Need a hand for this one, Setting a new drop down box and is working o.k. except for one little problem. When you click on the category to apply the drop down the background id white and I wanted transparent.
Any ideas will be appreciated.

Papa
Link is at http://shoppealot.com/g9-htm
Photo of papa

papa

  • 327 Posts
  • 20 Reply Likes
  • o.k.

Posted 10 years ago

  • 1
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
in the form code have you tried changing background:transparent to background-color:transparent
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
You could also try taking out the background code altogether.
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
would this work on a jot form form, i need mine to be transparant and lees suggestion dont work
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
That's what I did on mine! If you look on http://littleus.synthasite.com you'll see a mail form at the bottom of my screen. I took out the background code so that it'll blend in with my site.
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
so it should work, i will try it now.
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
errm, littleus, what is the bit im taking out... im lost!
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Hey Alex... go into your form code. You'll see a code at the very top. It says something like: background: white! important. take out the word "white". I think that's all you have to do.
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
okay
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
it worked!
http://sports-info.synthasite.com/con...

!its working!

Thanks Littleus

Alex R
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Great! Glad it worked out. If you ever need to change the color, you can add the color name there or the hex code.
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
thanks littleus, i will just leave it transparant so what ever colour the background is the form is!

thanks again,

alex
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
did you update your site? The form is still white.
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
yes i did
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
look at this image

this is my publishes site, what do you see?

alex
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
PS, the favicon bit on my internet is a bit rubbish, it will show a random favicon (for some reason)
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
This is what I see on FF:

Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
hmm. dont know whats up. i am having a look at this problem now.
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
It seems to be fine in IE though. You may have to go into your site builder on FF and apply the changes.
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
i dont heve FF anymore, my PC crashed
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Oh no. Maybe you could try downloading FF again? Although, I would have assumed that any changes you made in IE should be reflected in a different browser? Perhaps this is not the case.
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
i will download FireFox again edit the site i it then i will tell you here, then you test it and see if it works okay?
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
littleus, i cant figure out the problem, any ideas?
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
I don't know Alex. Maybe it's a bug in Yola or maybe it's your computer. It is strange though.
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
it cant be my computer, when it crashed everything was blanked apart from my documents & the it was upgraded. its twice as powerfull and it was powerfull before, it must b yola.
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Lemme see if I can change my form color and see if it reflects the changes on FF. One sec...
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
okay
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
It's making the changes fine on my end. I do think it's your computer somehow. I've noticed you've had many problems with the coding not working properly but for others it's fine. I went through this same problem before. My codes weren't showing up or the changes I made were not apparent. Then, I got myself a new computer and everything has been absolutely wonderful.
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
hmm, well the codes didnt work on my laptop either, is it my internet connection?
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
I have no idea Alex. Maybe it would be beneficial to send an email to Yola's support team. They may be able to determine what the problem may be.
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
good idea, sent & dun! (more like done!)
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
hi alex - i see white in IE and FF

you still have a background:white in the form code - try to change this.

this is IE

Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
i still have transparant, im stumped
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
I have transparent on IE still.
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
i think that FF because the navigation tabs dont look like that in IE. thats FF lee.
Photo of papa

papa

  • 327 Posts
  • 20 Reply Likes
Hi All
I have taken "TheDukes" idea and tried to change from "background:transparent;" to "background-color:transparent;"
Results were the same. Transparent till you drop down then white background.

Next I tried "Littleus" idea and remove all codes totally that related to color background.
This time main menu and drop down menu turn white w/ red lettering.

The I tried removing the text box next to the menu. Still had white w/ red lettering. That was the one i added to point to the problem menu now all gone.

I then reinstalled the background:transparent; and had transparent main menu and drop downs still white background.

Then I added -color back into code (background-color:transparent;) with same results.

Now for fun in the .initial2 section I change the color from transparent to purple and now have a purple high-lighted box around the word for drop down menu w/white background and main menu still remains unaffected and stay transparent. Except now there is a larger white box with purple bar w/ red lettering. (left this one on site)

This really got my mind working. I'll keep trying suggestion though.

I don't know but could the problem be in this code. When I remove it same results but the boxes get wider.

<!--//even removed this section totally//

/***********************************************
* Rollover background-color button Script- © Dynamic Drive (www.dynamicdrive.com)
* This notice must stay intact for use
* Visit http://www.dynamicdrive.com/ for full source code
***********************************************/

//Specify optional button target: "_new" for new window, or name of FRAME target (ie "myframe")
var buttontarget=""

function change(e, color){
var el=window.event? event.srcElement: e.target
if (el.tagName=="INPUT"&&el.type=="button")
el.style.backgroundColor=color
}

function jumpto2(url){
if (buttontarget=="")
window.location=url
else if (buttontarget=="_new")
window.open(url)
else
parent[buttontarget].location=url
}

//-->

I have no idea what this code does.

The other thing that I failed to mention is that when you hover over a drop down menu word there is a blue hover box. I look for this code for blue box and can not find it. Thought if I found it I'd also find that white background section.

Give a truck driver a computer and watch him go around in circles for hours and hours. lol

Thanks to all for your help and suggestions, we'll keep trying

papa
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Hi papa

The above code that you posted looks like if you click on a button, a new window will open up of a certain url. But, I am not experienced with this kind of stuff at all.. I cannot say with certainty. I'll take a look at your background problem and get back to you. Hopefully I can find a solution.
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Umm... I copied your code into a test page and everything came up transparent for me. I didn't even do anything! Have a look! This is in FF.

http://littleustestsite.synthasite.co...
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
I thought I better check what it looked like in IE. It's definitely different. The background of the submenu comes up completely purple.

I'll keep looking at it some more.
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
I think you might be missing part of the code?? Can you double check the source and see if you missed any part of it? In my opinion, the top part of your code looks a little off to me.
Photo of papa

papa

  • 327 Posts
  • 20 Reply Likes
Thank you Littleus.

I tried my code in 4 other of my site and still have the white background.I removed the purple on my test site and purple is gone. Will double check the code again. I've tried these sites from 2 different location and different serve and the problem still exists.
I checked the one out on your site and it does work perfectly. If there is nothing wrong with code it must be the way I'm holding my mouth when putting code it. lol

Thank you, again, for your help as it is deeply appreciated.

Papa
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
What browser are you using papa? I wonder if that's what the problem may be? Also, can you give me the link to where you got that code? It's still baffles me that the code looks a little off and that you can't change the hover color.
Photo of papa

papa

  • 327 Posts
  • 20 Reply Likes
I'm using firefox as ie8 or anything else is just to slow. Now I think it's my server as most any site i go to are slow. Partially with yola site. I even removed over 95 sites from yola and place them as parked domain and all 95 + load completely is 15 to 20 seconds as Yola I have had to hit refresh often as they time out. Like I said it's all 3 computers that i use or internet (Centurytel). Yola has always been good. Been trying to delete those 95 site and have to keep restarting computer and remove a couple at a time.
The code I used was a combination of two and came out to be the same type of effect that yola has for the page menu. Shoppzilla also use this type and both have white backgrounds and a blue hover box that don't disappear or is able to change on my sites.
What I'm like about this type of menu is that the sub category stayed on top of rest of menu. Others that i tired force the whole menu down and when you hit the bottom of sub-category you had to scroll back up page to get to next main menu.
The other type of menu that i tried at http://shoppealot.com/a60-htm seem to be good except on sub category that were lengthy and one have to search for the product that they came to see to start with. I believe the customer should be able to get to product with out having to search the page for it.
The first place that i used this menu was from http://www.shoppealot.com/a20-htm where as i took and removed the "go button" and drop the red category box off.
Then i place the code in there from http://www.shoppealot.com/master-temp... to try to get hover. Hover didn't work but was able to get drop down to function when you click on sub category and over lap the main category and only scrolled in the sub-category box. The only scrolling that has to be done was in sub-menu box, without having to scroll back up to main category box.
Some where out there is a category that I be Able to use as I get most code from http://www.dynamicdrive.com/ which seems like a good source in most cases.

If you can stop some thing or suggestion that would be great. Please don't waste to much time on it.

Thanks All
papa
Photo of papa

papa

  • 327 Posts
  • 20 Reply Likes
Littleus

I've seen one one of your site, Unless I Wrong, you had Babies R Us at the bottom of page. There is a company toy r us with a sister company at http://www.babiesrus.com.

One of my sites that I was going to use to sell office furniture threw was www.officeworld.co.cc but when www.officeworld.com found out they insisted I should not. Seems they were quite touchy about trademarks. I was more than happy to change my site to a women's site. I hope there customer don't get confused any more.
Don't want to see anyone get in to trouble with trademark.
papa