Mouseover Button won't show

  • 1
  • Question
  • Updated 9 years ago
  • Answered
Can someone help? The image for my mouseover button is not showing. I got the code and all, but it's not showing. Can anybody help? I'm new with mouseovers.
Photo of Grace

Grace

  • 76 Posts
  • 2 Reply Likes
  • confused.

Posted 9 years ago

  • 1
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Can you please try to post your code here? This way we can see if there are any errors made with your code and assist you. I'm sure we'll be able to figure it out.
Photo of Grace

Grace

  • 76 Posts
  • 2 Reply Likes
This is the code:
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
The code I have for mouseover images is this:

< img src="http://YOUR IMAGE FILE NAME" onmouseover="this.src='YOUR MOUSEOVER IMAGE FILE NAME';" onmouseout="this.src='YOUR IMAGE FILE NAME';" / >

(take out the space after the < and before the >)

Also.. you seem to have double http: You should only have one. Perhaps you only put them in so that the image doesn't show up.

I hope this works!
Photo of Peter

Peter

  • 2569 Posts
  • 113 Reply Likes
Hi littleus. The doubling of the http:// is due to the address input in the creator. It's quite ambiguous as it asks for the full address and implies that the http:// prefix is required.

You are right about removing occurrences of the double entry.
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Ahhh... I see. I guess it always good to check and re-check our coding! =)
Photo of Grace

Grace

  • 76 Posts
  • 2 Reply Likes
Okay, I did what you told me to do, but when I move my mouse over to the image, it won't change.
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
What is your url grace? I just want to see what you mean.
Photo of Grace

Grace

  • 76 Posts
  • 2 Reply Likes
Alright this is my site:
cgpage.synthasite.com
The image is there, but it won't show? Can you check if it shows on yours?
Photo of Grace

Grace

  • 76 Posts
  • 2 Reply Likes
Never mind. I solved it. Thanks for the help though!
(I must have added the wrong link)
Photo of Ed-a-Torials @ Honey Bear Playhomes

Ed-a-Torials @ Honey Bear Playhomes, Champion

  • 2582 Posts
  • 279 Reply Likes
Hi grace this code has served me well and worked without fail for as long as I have had a site...

1) The very first image "Home2.gif" is your mouse over and the other is your static image. You have one mouse over image URL and two static image URLs to change. When adding other buttons simply edit this code to include the URLs of those images as well as the link to URL

2) Change the
"loadimage1" (3 times in the code)
"image1" (3 times in the code)
"staticimage1" (3 times in the code)
for each button you use to something different each time (If you do not change these for each button and you have more than one button per page named the same thing both buttons will not work.)

Example:

"loadimage1" (3 times in the code)
"image1" (3 times in the code)
"staticimage1" (3 times in the code)

to

"loadimage2" (3 times in the code)
"image2" (3 times in the code)
"staticimage2" (3 times in the code)

as so on...

This is the code for your one button already changed...

http://gracesbuttons.synthasite.com/

had to put it on a page as getsatisfaction was reading the code...

It may seem like hard work but for you I think it will be a piece of cake as you are so smart... ;)

It is a really great mouse over button code.

Ed
Photo of Ed-a-Torials @ Honey Bear Playhomes

Ed-a-Torials @ Honey Bear Playhomes, Champion

  • 2582 Posts
  • 279 Reply Likes
arggg that shows me... I should read the posts somewhere in the middle of my long winded explanations. LOL