Mouseover not Mouseovering!

  • 1
  • Question
  • Updated 8 years ago
  • Answered
Hi
I've got a problem with a mouseover on this page http://www.leathersolutions.org/conta...
As you can see you can use it once then the base image disappears, its also not linking to my email address either
This is the code I used

<!--<a href="mailto:david@leathersolutions.org">-->http://sitebuilder.yola.com/sites/S3/...>

Any help would be appreciated,
PS I know the code is not displaying fully, perhaps someone could suggest a fix
Photo of David

David

  • 465 Posts
  • 94 Reply Likes

Posted 8 years ago

  • 1
Photo of petercsea

petercsea

  • 153 Posts
  • 19 Reply Likes
Hello David,

Would you like to see if this works. There appears to be a ot of extraneous code in the path of the mouseout image which may be the cause of the mouse-over issue.

Give us some more time on the mailto business and I'll refresh and learn some stuff.

<!--
<img src="resources/cooltext475011998.png" onmouseover="this.src='resources/cooltext475011998MouseOver.png';" onmouseout="this.src='resources/cooltext475011999.png';" />
-->
Photo of David

David

  • 465 Posts
  • 94 Reply Likes
Thanks Petercsea that's sorted the button out, the mailto I've used successfully before on a windows site
I f you wouldn't mind could you take a look at this page http://www.leathersolutions.org/the-g... I've got 2 yola brandings for some reason.
Thanks again
Photo of petercsea

petercsea

  • 153 Posts
  • 19 Reply Likes
Wow! How did you do that? And it's browser specific.

It appears as you describe in IE.
It looks stifled in Chrome
and different again with FF

I'm going to look at this a little more deeply. May I get back to you here if I can see any cause? It's probably very obvious to CSS lovers!
Photo of petercsea

petercsea

  • 153 Posts
  • 19 Reply Likes
David, I'm sorry but I can't explain it.

Nothing comes to me as i look at it. I'm sure someone will have an answer and it's probably some crossover effect in the styling or the flash parameters. Tables are notorious for doing similar things but I can't see any evidence of tables

I wonder if you noticed when it occurred? I mean was it apparent before your last widget addition? That may help identify the cause but not cure it

What I can suggest to do in the short term is to add a text widget beneath the flash widget and add as many "carriage returns" as needed to push the logo below the line of sight. "Out of sight; out of mind"
Photo of David

David

  • 465 Posts
  • 94 Reply Likes
I don't actually remember when it happened, it was not there one day and kinda there the next, it looks terrible so I need to sort it out some how, for now I shall do as you suggested.
If you have any more thoughts on the mailto please let me know
Thanks
Photo of David

David

  • 465 Posts
  • 94 Reply Likes
Hi Petercsea for your info I had the code slightly wrong for the mailto, I removed the --> from this .org>--><img and it worked

If anyone has any ideas on the 2 yola brandings please shout out
Photo of petercsea

petercsea

  • 153 Posts
  • 19 Reply Likes
That's great David.

I've been reading up to refresh my memory on "mailto:" and the thing that comes through very clearly is that it's on its way out. Mostly because it won't work if people don't have specific POP or IMAP clients installed. It doesn't work with web-based mail and although it works with Outlook it doesn't with Outlook Express.

The recommended alternative is to use a contact form of which there are a number of reliable one's around. including the recently released Yola form. Wufoo and Jotform are very reliable and quite easy to setup. Minus the orientation :) I think it may be something for you to consider since it is your business communication intake?

Of course it's just the current opinion and you know what you like and your clients preferences.
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Hello David

I took the liberty of fixing this up for you. You were missing a closing tag on your a href link which was causing the funny link. You will still need to update your site to apply this to your live site.

Please let me know if you have any further trouble with this.
Photo of David

David

  • 465 Posts
  • 94 Reply Likes
That's interesting especially the outlook express bit, it does however work with windows live/hotmail, it takes you directly to your sign in page.

I think I'll start a fresh thread regarding the two yolas as its probably lost amongst this.
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Hello David - just to let you know that I have already addressed your "2 yolas" issue. Look above :)
Photo of David

David

  • 465 Posts
  • 94 Reply Likes
Thanks Sanja, I had a text widget to drop the branding down which I now can't delete. There's a bit to much white space underneath.