Moving Yola Site to Amazon EC2

  • 1
  • Question
  • Updated 10 years ago
  • Answered
Hi, I just moved my site from Yola to Amazon's EC2 (because of page load times) and I'm having some issues. I copied my entire site to /var/www so all the relative paths and dependencies should work but when I try loading the php pages that worked perfectly fine on Yola I run into the following issues:

1. When I load index.php as is nothing happens. A blank page appears

2.. When I insert print statements at the beginning of index.php script, the print statements get rendered in the browser but then I get the following two warnings:

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /var/www/about-us.php:4) in /var/www/about-us.php on line 21

Warning: Cannot modify header information - headers already sent by (output started at /var/www/about-us.php:4) in /var/www/about-us.php on line 22

I did some research and found out that I could get rid off the first one by having session_start() as the very first line in the php script. (It is still less than desirable because I don't want to have to do this for every php file. Is there a server side solution, perhaps in the php.ini file? How can I get all the php config information used in Yola? What files contain this information? How can I view them?

3. I also did some research on the second warning and it appears to be caused by white space before or after the opening and closing php tags. I have verified that my index.php and all the included files do not contain spaces before or after. Is there some other cause of this problem? I have also verified that I am using php 5.2.x or greater. (The specific version I am using is: PHP 5.2.4-2ubuntu5.6 with Suhosin-Patch 0.9.6.2 (cli) (built: Apr 17 2009 14:31:37) ).

Any help will be greatly appreciated!

Thanks!
Photo of j Kuria

j Kuria

  • 2 Posts
  • 0 Reply Likes
  • Frustrated

Posted 10 years ago

  • 1
Photo of Ruth

Ruth

  • 2819 Posts
  • 135 Reply Likes
Hi j Kuria,

Can you give these details to your hosting company?

Hosting with your own service provider:
Copy the site to the webroot of a php 5.2.x enabled web server
* Ensure that the "classes/work/templates_c" directory is writable by the web server (chmod 777 classes/work/templates_c on Unix / Linux boxes).
* Ensure that your host supports Sqlite3 if you have a blog on your site.

Unfortunately, because we no longer have any knowledge of, or control over, the environment of your hosting provider we can now only support you with:

* building your site
* downloading your site as a zipped file
* giving you instructions to pass on to your hosting provider on how to upload the site. (the ones you see in our publishing dialog box when you select the third option)

Our expectation is that this option will either be used by advanced users who understand these instructions or people who can pass these on to a hosting service who can do everything necessary on their behalf.

If an error occurs when you try to upload your site to the server of another host we cannot help you. Not because we do not wish to, but because we are not able to, as we do not have access to your hosting environment. We constantly test our publishing environment to make sure that everything is working properly. We have no way of testing our sites on the servers of another host.
Photo of j Kuria

j Kuria

  • 2 Posts
  • 0 Reply Likes
* Ensure that the "classes/work/templates_c" directory is writable by the web server (chmod 777 classes/work/templates_c on Unix / Linux boxes).

That did it! Thanks a lot! You guys rock--better support than some paid services!
Photo of Ruth

Ruth

  • 2819 Posts
  • 135 Reply Likes
Glad to hear it worked for you.