mp3 widget: which one should I use?

  • 1
  • Question
  • Updated 9 years ago
  • Answered
I link to many mp3 on my file manager via the word "listen". According to my visitors, sometimes they play immediately in WIndows Media Player, sometimes QuickTime, sometimes they need to be saved to file, sometimes nothing happens at all or they have to wait for download. How can I make this more consistent and reliable. I saw some answers about "widgets." Is that the appropriate fix? But there are so many; how do I know which to use? And then do I install a widget for each file, or one for the whole page? My site is www.raulkottler.com. I feel pretty stupid because the answer is probably already answered but I cannot find it Thank you for your help. Raul
Photo of Raul Kottler

Raul Kottler

  • 1 Post
  • 0 Reply Likes
  • perplexed

Posted 9 years ago

  • 1
Photo of Emmy

Emmy

  • 5892 Posts
  • 299 Reply Likes
Hello Raul,

The way this happens has to do with how the person has their browser set up and what they have installed on their computer. Unfortunately it is hard to make it more consistent as each person will have something a bit different.

I listened to the music a bit on your site, very beautiful!

Emmy
Photo of Woolyback

Woolyback

  • 53 Posts
  • 1 Reply Like
Hi Raul
I tried your site and pressed to listen to a piece of music, it downloaded the piece to my windows player and everything was ok.
However to get over the problem of people having different players, have you consided streaming the music direct from your site?
I hadn't tried this myself so I had a quick test.
I opened my site in the edit screen and dragged the 'Widgetbox Gallery' button on to it (you could put it under each piece of music).
When the gallery button opened I chose the 'mp3 Player' button next to the Google one.
This opened the widget properties where you can edit the size and colour of the button, (I left this as default for test purposes) and then entered the url of my music file which I had uploaded to my file manager.
The full url was http://mysite.yolasite.com/resources/...
subsitute this for your url in the link to your 'listen' text.
I pressed the 'get widget' button and it appeared on my site which I then published and went to my site to test it.
At first pressing the mp3 button did nothing but the second time I tried the 'hand' icon appeared and another press started the music playing.
Hope this helps.