My Mouseover Image is jamming!

  • 1
  • Question
  • Updated 9 years ago
  • Answered
Help my Mouseover image is jamming look at
http://yo-sites.synthasite.com (hover over the Contact us image, then the library image, its ment to do what the library image does)

thanks

al

http://yo-sites.synthasite.com
http://logikomedy.synthasite.com
http://digitaldiscmakers.synthasite.com
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
  • Help!

Posted 9 years ago

  • 1
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
the links going to a placeholder page
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
Photo of Ed-a-Torials @ Honey Bear Playhomes

Ed-a-Torials @ Honey Bear Playhomes, Champion

  • 2582 Posts
  • 279 Reply Likes
hey Alex

Change the code for the "Contact us" button

You have the first image URL as "contact us 2"... It should be the image URL for the button of "contact us 1"

Happy site building
Ed
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
the code for the first 1 is
onmouseout="this.src='http://sitebuilder.yola.com/sites/D66..."

the code for the 2nd is

onmouseout="http://sitebuilder.yola.com/sites/D66..."

You see how its missing the - this.src=

maybe that is the problem

Lee
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
well i just copied and pasted the code from the "library" code then changed the images, i will post the 2 codes in a momen
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
alex... I posted in your other thread.... your library code is fine. What probably happened is when you pasted your image url, you accidentally pasted on top of the "this.scr=" code. Your library code has that code as well.
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
hmm, i will check my code b 1 Mo!
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
HELP! how do i copy and paste on a Mac?
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Instead of having to copy and paste... just type in after your onmouseout=

"this.scr=

no spaces before or after that little code
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
still nothing, it is still jamming =(
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
lemme take a look again
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
oops.. can't get in
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
heres the strange code...

--!>

al
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
would you mind publishing your site again. I think there is just a small typo or something. Also.. if you want to wrap your code use this <!-- -->
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
hmm not workin...
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
i did, it sill wont stop formatting

updated
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
code again

<!--<a href="http://yo-site.synthasite.com/contact... style="border-width:0px" src="http://sitebuilder.yola.com/sites/D66..." onmouseover="this.src='http://sitebuilder.yola.com/sites/D66..." onmouseout="this.src=http://sitebuilder.yola.com/sites/D66..." /></a>-->
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
you forgot the " before the http:// on your onmouseout
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
oops! i will edit it and hopefully it should work!
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
and still, no result, it STILL wont work, just jams, and its the 5th time i have re-made the code
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Okay Alex... take a deep breath now. I know it's frustrating, especially when you're so close. You know that the Library code is working. So, obviously there is something amiss in your Contact code. Oops.. this time I think it's my fault. It's supposed to be ' not " - the single one. Try that.
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Hi Alex... did you get it resolved?
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
nope not yet =( over night i have made 3 ore attempts at it but still, nothing >:/
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
littleus! i have fixed it it finaly works!

& i have added a 3rd one!

thanks

al
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
Hi Alex this code worked for me sorry i didnt send it earlier

<!--
<a href="http://yo-site.synthasite.com/site-li... style="border-width: 0px;" src="http://sitebuilder.yola.com/sites/D66..." onmouseover="this.src='http://sitebuilder.yola.com/sites/D66..." onmouseout="this.src='http://sitebuilder.yola.com/sites/D66...>

<a href="http://yo-site.synthasite.com/contact... style="border-width: 0px;" src="http://sitebuilder.yola.com/sites/D66..." onmouseover="this.src='http://sitebuilder.yola.com/sites/D66..." onmouseout="this.src='http://sitebuilder.yola.com/sites/D66...>

-->
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
its ok lee, i have done it now, and i am making 2 more as we talk!
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
all i did to get this was copy the working button code and then change the images - remember if you have 1 working piece of code its easy to replicate it and then just change the image source.

Sites looking great - well done
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
thanks lee BUT i have made 1 more and now thats jammed i have re made the code 3 times and still its jammed see at http://yo-site.synthasite.com its the "Terms" Button.

HELP!
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
I told you how to do it above - here is the code you need

<!--

<a href="http://yo-site.synthasite.com/terms-o... style="border-width: 0px;" src="http://sitebuilder.yola.com/sites/D66..." onmouseover="this.src='http://sitebuilder.yola.com/sites/D66..." onmouseout="this.src='http://sitebuilder.yola.com/sites/D66...>

-->
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
FIXED IT! nevermind! i know what the problem is, just 2 or 2 code problems!

thanks everyone for all your help!

al

http://yo-site.synthasite.com
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
to make a new one just copy the code then change the link url and the image urls - easy
Photo of Boomer

Boomer, Champion

  • 2055 Posts
  • 84 Reply Likes
Alex,

It looks like you are referencing to the image URL's as they
appear in the site builder e.g. http://sitebuilder.yola.com/sites/......

Your image URL's need to look something like this:
http://yo-site.synthasite.com/recourc....
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
yes, i have done that beacuse i cant get to the page that i host my files on, it never lets me on it so i have to preview it!
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
Alex i tell you that all the time - try just resources/filename.png
the images are only displayed and hosted on your site so there should be no need for the url at all
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
ohh, well the code usualy automaticaly does that, its hosted an a different site called testsiteddm. do i still do the same?
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
the image is at your site thats all that matters, the code is from that site its not hosted at that site,
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
when a browser reads code, when its reading it at your site its already up to the yo-sites.synthasite.com/ - - its already in that folder, thats why you dont need it, like a page link in your site does not need all the http://----.com/ its already up to that point -- hope this makes sense
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
but its hosted an "another" website that i made...
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
so i still need the http:// bit because it is not "held" at yo-site
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
it is held at your site - you have copied it into the editor
if you look at the code for a nabble forum you will see its just a link - thats because the code is hosted 'held' somewhere else - however if you llok at a formassembly code it is hosted 'held' at your site
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
ohh! now i fully inderstand what you mean!
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
ohh! now i fully inderstand what you mean!
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
ohh! now i fully inderstand what you mean!
Photo of Alex

Alex

  • 3448 Posts
  • 39 Reply Likes
ohh, so i just need /resources/IMAGE FILE.IMAGE TYPE ?
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
unless you want it to be used on other sites you just need that, yes