My pictures don't show up! Help?

  • 4
  • Problem
  • Updated 10 years ago
  • Solved
I uploaded a picture to one page, and it shows up fine when I view my site. My other pictures on a different page, however, only show up when I'm in edit mode- not when I'm simply viewing my site through a browser. Help?
Photo of Anie

Anie

  • 3 Posts
  • 0 Reply Likes
  • frustrated

Posted 10 years ago

  • 4
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
There could be a couple of things you could do!

1. Be sure to update your site after uploading your files to your file manager.

2. If you're using HTML, make sure you have the correct path to your images.

3. Try clearing your cache and then logging back into your site.

Would you mind sharing your site url so that we can take a look and see if the images are showing up for us?
Photo of Emmy

Emmy

  • 5892 Posts
  • 299 Reply Likes
Thanks littleus, looks like we were posting at the same time. Thanks as always for you help!
Photo of Emmy

Emmy

  • 5892 Posts
  • 299 Reply Likes
Hi Anie,
A few things, when you added the images to your site that are not showing right now, did click the yellow Update Site button for the changes to appear live? Also, how did you add the images to the page, via the image widget or text widget? If you could give me a link to the page that they are not displaying on I will take a look.

Thanks,
Emmy
Photo of Anie

Anie

  • 3 Posts
  • 0 Reply Likes
Hi Emmy,

Thanks so much! Updating worked. I thought "Save" was the same as "update" (I thought it meant Update, like, purchase the domain). Thanks again!
Photo of Emmy

Emmy

  • 5892 Posts
  • 299 Reply Likes
Wonderful Anie, glad to hear that worked!