my site will only work if I have the subdomain checked as primary, but then displays the subdomain in the url bar.

  • 1
  • Problem
  • Updated 8 years ago
  • Solved
I have a website built and hosted through Yola ( We own the domain and it is registered through hostgator. We haven't had any problems since we first put the site up, but now when you go to the url it puts you on a yola page saying that "this sub-domain is available." At that time we weren't using a subdomain at all. To try to fix this I registered the subdomain, and as long as I have the subdomain selected as the primary domain in the advanced domain settings, it works, but then the subdomain shows up in the url bar. If I have the main domain selected as primary and try going to the url Mozilla tells me that it is in a cycle that will never end.
My site is up for the time being, but the subdomain comes up in the address bar, which is not what I want. Any ideas?

Photo of Steve


  • 1 Post
  • 0 Reply Likes
  • not liking this

Posted 8 years ago

  • 1
Photo of Dré


  • 201 Posts
  • 15 Reply Likes
Official Response
Hi Steve,

I have taken a look at your domain and I can see the problem.

It looks like has not been configured to point to your Yola site. When I look at the settings, I see that both A records are not pointing at Yola IP address of but rather another address:

You will need to configure your domain name to point to Yola. You do this by creating A records (address record) to point to this IP address: "".

We have a tutorial outlining the steps to configuring your domain: < a href=" to a domain you already own.

For detailed instructions for a few specific domain registrars please click on this link: Domain Configuration with GoDaddy, & other domain registrars.

Once you've pointed your domain, watch a step-by-step video on how to publish your site using a domain you already own, please see: Publish to an external domain.

Once your domain is setup correctly you will then be able to set it as the primary domain for your site.

This should do the trick!