My swf file cannot load its xml file

  • 1
  • Question
  • Updated 9 years ago
  • Answered
Here's the link:
http://genji.yolasite.com/xwords.php

I think resources/Xword01/cwf_live.swf is loading fine, but then it comes up with the error message "cannot load puzzle.xml", which is also in resources/Xword01/
Photo of genji

genji

  • 4 Posts
  • 0 Reply Likes
  • confused

Posted 9 years ago

  • 1
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
file names are case sensitive - make sure this is all ok.
Photo of genji

genji

  • 4 Posts
  • 0 Reply Likes
Thanks Duke - yes everything's correct in that respect. Only the 'X' in Xword01 is capitalised. It's the swf file that can't load the xml file, although it works fine locally.
Photo of Ed-a-Torials @ Honey Bear Playhomes

Ed-a-Torials @ Honey Bear Playhomes, Champion

  • 2582 Posts
  • 279 Reply Likes
Genji

I have a fair bit of experience in working with SWF slideshows and transitions which make use of an XML file to bring up images and when looking at your source I don't see anywhere in the embed code where it brings up an XML file. I do see the SWF file location but no mention of an XML.

Could you please post the URL of the website that you acquired the code and crossword from. I know the location in your resources folder of both the SWF and the XML and maybe I can find a code that will work for you if I know where you got it from...

Happy site building
Ed

You can find me with my head in the honey pot here..

Honey Bear Playhomes Tips and Favs in one place... A Honey bear Playhomes Tip ;)
Photo of genji

genji

  • 4 Posts
  • 0 Reply Likes
Hi Ed - thanks.

The swf file and the xml file were generated by a crossword application (publish to web), which creates a folder with three files - those two and an html file that cannot be uploaded to yola, but which also does not refer to puzzle.xml.

The html code that starts the swf is from the yola FAQ. cwf_live.swf appears to start okay and as you can see, it generates (in tiny little letters) the error "cannot load puzzle.xml".

I don't think I can post HTML code here without it being parsed so I'll add the code to a new page on the yola site where it can be viewed as source...
Photo of genji

genji

  • 4 Posts
  • 0 Reply Likes
I got it working. I re-did the export (publish to web) but enabled URL parameters. This specified the name of the .xml file in the code, to which I just added the directory path.
Photo of Ed-a-Torials @ Honey Bear Playhomes

Ed-a-Torials @ Honey Bear Playhomes, Champion

  • 2582 Posts
  • 279 Reply Likes
Great job genji... I knew that you could do it...

It seem missing code comes up for every one of us so just feel happy you got it all sorted out. Now on to the next learning experience ;)
Photo of diane

diane

  • 1238 Posts
  • 121 Reply Likes
I seem to be missing code too but I'm not sure what it should be. I have a Flash gallery generated by JetPhotoStudio. There's a swf file, xml file and html file but it doesn't appear to be calling the xml file. I believe this is the bit here: <!-- <param name="allowScriptAccess" value="sameDomain" /> -->
but when I replaced "sameDomain" with the url of the xml file it does nothing. There is no mention of the xml in the html at all.
Photo of lambofgod

lambofgod

  • 875 Posts
  • 35 Reply Likes
hmm, I'm going to go make a JetPhoto gallery so I can see the entire thing. Then I might be able to help you out.
Photo of lambofgod

lambofgod

  • 875 Posts
  • 35 Reply Likes
sorry to be a bother, but I can't seem to find the site. Would you share it's url?
Photo of diane

diane

  • 1238 Posts
  • 121 Reply Likes