Ok... Yola... I want this feature! lol Another request!!!

  • 1
  • Question
  • Updated 8 years ago
  • Answered
I would really, really like to be able to put an external link in my yola created menu. I have ideas that's going to require creating a custom menu but would be so much easier to have this option in yola since I've never been able to make the custom menus work right.
Photo of Donald

Donald

  • 2991 Posts
  • 37 Reply Likes
  • http://youcanneverbetoosmart.com

Posted 9 years ago

  • 1
Photo of Kershnee

Kershnee

  • 2087 Posts
  • 152 Reply Likes
Hi Donald,

Thank you for your request. Not sure if this is what you are looking for, but here is the info anyways:

Here are steps that will allow for your menu link to redirect to an external URL :

1. Create a new page with the name of the site you want to link to.
2. Drag and drop a HTML widget onto your page.
3. Paste this tag into the HTML editor:
<meta http-equiv="refresh" content="2; url=http://webdesign.about.com">

"2" is how many seconds it waits before it redirects - you can change this number.
"url" is the URL it redirects to, so, replace the URL in the above tag with the one for the site you want to link to.
Photo of Donald

Donald

  • 2991 Posts
  • 37 Reply Likes
yes, I'm aware of redirects... but it goes to the "new internal page" first right? That's unprofessional!
Photo of jcgray65

jcgray65

  • 5 Posts
  • 0 Reply Likes
I agree ! I want to do the same...but go directly to my forum...how can I do this please ?
Photo of Marije

Marije, Official Rep

  • 4636 Posts
  • 237 Reply Likes
Hi there - have you tried the steps that Kershnee's outlined? You can also find them on this link: http://www.yola.com/customer-support/...
Photo of jcgray65

jcgray65

  • 5 Posts
  • 0 Reply Likes
I did ! But as myself and Donald have said. It's an internal page first , we want the link in the menu bar to go DIRECTLY to the external webpage. Please can you re submit a response ?
Photo of Marije

Marije, Official Rep

  • 4636 Posts
  • 237 Reply Likes
I'll be sure to pass your request on to our development team. Unfortunately I can't tell you when a feature like this would be available.
Photo of SilverX

SilverX

  • 492 Posts
  • 40 Reply Likes
Hi Donald,
yes its true that you can't direct link to an another host.
Also Yola users cant put in WYSIWYG editor.
The onlything we can do is Kershnee's method.

Alternately you can build your menu yourself (flash) so you can add ANY link to it.
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
Hi jcgray65,

Change the redirect content value to 0.

You could create a page that deals with the request, make it either all white (or a colour to match your sites main background colour) or include on the page a loading GIF - Users won't even realise whats happened.
Photo of jcgray65

jcgray65

  • 5 Posts
  • 0 Reply Likes
How do I make it 'deal with the request ' ?

Do you mean when it went to the internal 'forum' page....I could put a loading gif in and it would automaticaly redirect and load to the external forum if i set the redirect to 0 ?
Photo of UK Duke

UK Duke, Champion

  • 3321 Posts
  • 213 Reply Likes
exactly that, when I said 'deals with the request' I just meant executes the redirect code. The point is if you are clever and make the redirect page very subtle your users won't understand what has happened.

Hope this helps - Lee.
Photo of jcgray65

jcgray65

  • 5 Posts
  • 0 Reply Likes
Thanks ! Ok I've added the gif and the link to my forum. I cant see where I place the '0' to redirect. Also it is not re-diredcting ? Can anybody see what I am doing wrong ? There is no 'link ' icon in the edit page ..so I have done it in the properties.
Photo of Emmy

Emmy

  • 5892 Posts
  • 299 Reply Likes
Hello jcgray65,
What you need to do is use the steps that Kershnee gave above with the HTML widget and the redirect code snippet. Where you need to put '0' is where it says content="2 make that a 0. As soon as you put this code on the page it will redirect automatically, including the Sitebuilder page. Hope this helps!
Photo of jcgray65

jcgray65

  • 5 Posts
  • 0 Reply Likes
I did it...and it worked ! I would prefer it to go immdiately to the Forum but it's the nearest way of doing it without a direct link. It looks great and the loading gif lasts the blink of an eye and my users are there on the Forum.

Thanks !