Page Header and template selected has gone all white and made font invisible.

  • 2
  • Question
  • Updated 7 years ago
  • Answered
Hi, I have a problem with my Page Header. All of a sudden, the original template colour of the background and font colour have gone to colour white. I can see the text when I scroll over the text but cannot do anything with it as it does not allow this...
Photo of David Verlaque

David Verlaque

  • 2 Posts
  • 0 Reply Likes
  • anxious

Posted 8 years ago

  • 2
Photo of Marije

Marije, Official Rep

  • 4636 Posts
  • 237 Reply Likes
Hi David,

Please could post a link to the particular page of your site where you are experiencing the problem so that we can take a look.
Photo of David Verlaque

David Verlaque

  • 2 Posts
  • 0 Reply Likes
Hi, the web page is http://rrya.yolasite.com/ and the problem is with all pages...
Photo of Marije

Marije, Official Rep

  • 4636 Posts
  • 237 Reply Likes
Hi David,

Thank you for posting the link - this is a bug on our side (on this particular style) that has been logged for a fix. Unfortunately I can't tell you when the fix will go out and we will post back here when it has been fixed.

If you can't wait for the fix to be released, I can only recommend that you consider changing to a different style (click on the "Change Style" button). The particular style you've chosen does have two other color variations that may suit you.
Photo of Emmy

Emmy

  • 5892 Posts
  • 299 Reply Likes
Hello David,
I am happy to report that this bug with this style has been fixed! Thanks so much for your patience while we worked on that, and please let us know if you have any further troubles.

Kind Regards,
Emmy
Photo of Martin Underwood

Martin Underwood

  • 59 Posts
  • 1 Reply Like
My problem exists at: http://pctfantasyfootballleague.yolas... and the pages affected are: Index, Spring 2011 Stats and a few offline pages.
Please can you help sort it for me as I've just finished designing the site only to find this problem.
Thanks for your time,

Martin Underwood
Photo of Martin Underwood

Martin Underwood

  • 59 Posts
  • 1 Reply Like
...BTW My problem only arose when I added an HTML box to the page. As I'm only just starting to get to grips with HTML, the problem could well be in the programming. Can you check and alter this if I give you my permission to do so?
Thanks again,

Martin Underwood
Photo of Martin Underwood

Martin Underwood

  • 59 Posts
  • 1 Reply Like
...I have tried changing the style and the problem still exists (so I changed it back to the original style before writing this). All I can put it down to is a slight error in the HTML programming. If you can offer any help I would be extremely grateful.
Yours,

Martin Underwood
Photo of Emmy

Emmy

  • 5892 Posts
  • 299 Reply Likes
Hello Martin,
I am going to ask our HTML team to take a look at your site as you have mentioned that fact that an HTML Widget as added before the problem started.

Thanks,
Emmy
Photo of Martin Underwood

Martin Underwood

  • 59 Posts
  • 1 Reply Like
Thank you.
Photo of Andi North, Mangopear Media

Andi North, Mangopear Media

  • 782 Posts
  • 111 Reply Likes
Hello Martin,

I have diagnosed the problem as an additional background attribute, basically this means that your custom HTML will contain some CSS (styling) that changes the background colour of the page.

I then looked at both the Index and Spring 2011 page and found that the only common element are the tables. So I looked at your Page sources and found the following issue:

<!---

HisPage :: Sports League :: www.hispage.nl&lt;/title>
<style type="text/css">
/* default colors and fonts */
body {
background : #FFFFFF;
font-family : Verdana;
font-size : 11px;
color : #000000;
text-align : center;
}

/* all hyperlinks */
a {
color : #CC0000;
text-decoration : none;
}

--->

The issue with this is the background bit. I found this under the HTML widget for your table on the index page. You will have to go through and delete the first part of every table as follows:

HisPage :: Sports League :: www.hispage.nl [[[Please note that this is created by Yola but I have shown for clarity]]]

/*all hyperlinks */
... rest of code as normal...

Hope this helps, I have tried to be clear but am tired so may not come across so.

Andi
Photo of Martin Underwood

Martin Underwood

  • 59 Posts
  • 1 Reply Like
Thanks very much for all your time and efforts. I will follow your instructions tomorrow and let you know how I got on.

Thanks again,

Martin Underwood.
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Do keep us apprised Martin! We're eager to hear how this works out for you. :)
Photo of Martin Underwood

Martin Underwood

  • 59 Posts
  • 1 Reply Like
<!---

HisPage :: Sports League :: www.hispage.nl&lt;/title>
<style type="text/css">
/* default colors and fonts */
body {
background : #FFFFFF;
font-family : Verdana;
font-size : 11px;
color : #000000;
text-align : center;
}

/* all hyperlinks */
a {
color : #CC0000;
text-decoration : none;
}

--->

Hi again,

I don't know if I've read last night's message correctly, but am I to delete the lines:

HisPage :: Sports League :: www.hispage.nl (and) /* all hyperlinks */
or do I delete the rest of the text that you've quoted too?

If it's the first, I tried that on just the Home page (index) and nothing seemed to change, even after deleting my browsing history.

Sorry for being a nuisance but after putting in a lot of hours it would be nice to finally get it right.

Thanks again for your help,

Martin Underwood
Photo of Andi North, Mangopear Media

Andi North, Mangopear Media

  • 782 Posts
  • 111 Reply Likes
Sorry,

You should delete the
body {
background : #FFFFFF;
font-family : Verdana;
font-size : 11px;
color : #000000;
text-align : center;
}

Andi
Photo of Martin Underwood

Martin Underwood

  • 59 Posts
  • 1 Reply Like
Hi Andi,

Followed your last message and now the whole page from the header down has a black background with coloured text... in fact the only text that has a white-ish background is in the HTML box. I haven't saved the last editing so do I just cancel so at least I return to the previous state?

Please help,

Martin Underwood
Photo of Martin Underwood

Martin Underwood

  • 59 Posts
  • 1 Reply Like
... it had the same effect as it would have if I had changed the line "background : #FFFFFF" to "background : #GGGGGG" (if that helps).
Photo of Andi North, Mangopear Media

Andi North, Mangopear Media

  • 782 Posts
  • 111 Reply Likes
Hello Martin,

The issue is that the HTML has broken the page and now all content is outside of the content area. If you put the background as black again, you'll see the grey outline with the white space under the banner. I am going to try and find the fix for you.

Andi
Photo of Andi North, Mangopear Media

Andi North, Mangopear Media

  • 782 Posts
  • 111 Reply Likes
Right,

I have checked and it works if you delete the following:

background: #FFFFFF

I have deleted this from the Spring page and it works there. Do this for all of the pages with the tables that have come with the CSS styling.

This issue with the home page seems to be the Flash content at the top. I can not confirm it but I believe that is the issue.

Andi
Photo of Andi North, Mangopear Media

Andi North, Mangopear Media

  • 782 Posts
  • 111 Reply Likes
The index page is behaving as if there is no content in it.

If someone from Yola could have a closer look but I can not figure what is causing it.
Photo of Andi North, Mangopear Media

Andi North, Mangopear Media

  • 782 Posts
  • 111 Reply Likes
Okay Martin,

What I recommend you do is recreate your index page. Do it in the following way:

1. Add a new page and name is Index 2.
2. Copy over all of the content - one piece at a time!
3. Preview after every piece added.
4. Notice when the page breaks and let us know.

This is how we will be able to analyse the suspect item and fix it for you.

Hope you understand this, if not please let me know.

Andi
Photo of Martin Underwood

Martin Underwood

  • 59 Posts
  • 1 Reply Like
Hi Andi,

Funny you should suggest this. I did the very same thing yesterday as I thought it would reveal where the problem lays.
* I started by creating a new index page...added a text box at the top and entered the title...
* then I added a multimedia MP3 Player with a music clip that's in my storage area...
* I then added a splitter widget to cut the page into two...
* I added a text box into the left half and copied/pasted written text into it... * then added a second text box into the right box and copied/pasted the remainder of the written text...
* I then added a further text box at the bottom of the left half with the group's email address and added a link to that email address so that anyone clicking on it will automatically open a blank email page with the address on the "to" line...
* That left an area in the bottom right half. This is where I placed the HTML box that is causing all the problems. I deliberately did this job last as I suspected it was the cause of my problems and I was proved right as the black border disappeared once the HTML was saved.
I hope this info helps,

Martin Underwood.
Photo of Martin Underwood

Martin Underwood

  • 59 Posts
  • 1 Reply Like
...follow-up to the advice "delete background: #FFFFFF" - I have done this to a number of pages and as you said, it does work and I have been able to rescue these. However, there are a lot of pages (Teamsheets) that suffered an adverse effect with the majority of the page turning black.
I know that neither Yola or HisPage are to blame. It's my error and it's only to be expected when little more than a week ago I neither knew how to copy or create HTML into the HTML widget nevermind what it all meant.
I've imputted data into the HisPage Sports League program and once I hit a button it produced a completed page as it would appear on the internet. I then clicked the right mouse button anywhere on the page, in the menu box that opens I clicked on "View Source", a HTML box opens and then I copied the HTML and placed it the HTML widget on my Yola page before editing it to meet my requirements.
It's only through reading and studying the HTML that's produced by the program that I've begun to understand (in some small way) how some of it works and how to alter it to do the things I want it to do.
My nephew found Yola through Google and after a couple of hours I realised what a good website creator Yola is... even the free version. If asked where the best place to create a webiste is, I wouldn't hesitate to say Yola.
I really appreciate everything you are doing to help me.

All the very best,

Martin Underwood.
Photo of diane

diane

  • 1238 Posts
  • 121 Reply Likes
Hi, Martin,

I'm a bit late to this. Thanks very much, Andi for helping out! There appears to be some additional code that is interfering with the page. I am just not sure what background you are wanting. Do you want it black or white with black text? The index page appears readable--there is still bad code though as indicated by the Yola footer being in the wrong place. Please let me know what this is supposed to look like. Thanks!
Photo of Martin Underwood

Martin Underwood

  • 59 Posts
  • 1 Reply Like
Hi Diane,

What I was looking for (on all pages) was a black border with white pages and mainly black text (with some instances of coloured text).
A lot of pages are being 'recovered' but those that remain have white borders.
As for the bad code, it doesn't surprise me. It's more than likely a mistake I've made when I've changed table content within the HTML (I need to find an Adult Training class in HTML programming). :)
Thanks for your help,

Martin Underwood.
(inexperienced in HTML)
Photo of Martin Underwood

Martin Underwood

  • 59 Posts
  • 1 Reply Like
I sympathise with you guys. With all the enquiries you must get and all the HTML and technical issues you must have to check, it must be very tiring. I've been at it all day (on and off) trying to correct this border issue caused through HTML and at 2.15am I'm shattered.

What makes it worse, I've messed up the Spring 2011 results page as the two halves of the page seem to have merged (where a three mm gap once was) and I can't do anything about it.

Goodnight to anyone who gets to read this...
Photo of Andi North, Mangopear Media

Andi North, Mangopear Media

  • 782 Posts
  • 111 Reply Likes
Hi Martin,

Would you mind creating a new page and copying all of the text over. But do not copy the table over.

Or, if you are not going to add any more content to the page, you could add this in a HTML widget.

Without the <!--- and --->

<!---

<style type=text/css>

#page {
height: 1425px;
}

</style>

--->

I have tested using Google Chrome Developer tools and it works for me.

I presume you do not have Yola Silver but if you do, open the Custom CSS and put height: 1425px; under the Page tag.

Andi
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Hello Martin

I've been investigating your site and there is definitely something amiss. Please do leave this with us for a few days as we try to sort it out.
Photo of Martin Underwood

Martin Underwood

  • 59 Posts
  • 1 Reply Like
Dear Andi and Sanja,

(Andi) Thank you for your advice. I might act on it depending on what they say at Yola. Your help is always appreciated.
(Sanja) I will gladly leave it with you for a few days. I would appreciate it if you could let me know once you've conducted your investigations as I won't be touching it now just in case it hinders what you are trying to do.
One thing about me, I am stubborn not a quitter. One way or another I will carry on until the problem is solved or I make myself ill trying (LOL).
All advice is gratefully received and once I become more proficient, I hope to be able to pass on what I've learnt to others.
All the very best (and have a nice weekend),

Martin Underwood.
Photo of Andi North, Mangopear Media

Andi North, Mangopear Media

  • 782 Posts
  • 111 Reply Likes
No problem Martin,

Hope it all works out! There is definitely something wrong with the table. You said that you copied and pasted it from a website, could you supply the direct URL, this would be helpful - to both the Yola team and to me. Is it just because you did not know how to create a table or does it provide some sort of automatic update?

If it was just because you did not know how to create a table, I could supply you with the correct HTML, as I have Dreamweaver which means I can create tables in a jiffy!

Andi
Photo of Martin Underwood

Martin Underwood

  • 59 Posts
  • 1 Reply Like
Hi again Andi,

The program I use is called Sports League (latest version) and is by HisPage (you might find it on Google) who are Dutch. Their website is Dutch but is also written in English for English speaking visitors.

Once you downloaded the program you can then open it everytime a match is played, type in any information, and then click on a button that creates a FTP file or another that creates a HTML file. At the same time it opens a preview page to show you how the page will look once on your website.

Instead of producing FTP or saving the HTML, I wait until the page opens and right mouse button click on it. A menu appears whereupon I click on View Source. A HTML box opens. I then copy and paste the HTML into my Yola HTML widget. It is then that I edit (as best I can) the contents of what will be the table - e.g. If the title of one or more table boxes are not in the order I want it them then I will go into HTML and re-title the boxes.

It's through reading the HTML produced by the aforementioned software that I've learnt how to change the colours inside a table box in order to highlight the team leaders, etc. and create my own table such as the one causing me the trouble on the index (home page).

The table is correct in it's appearance but something about it is causing the conflict with the border colour of the page. That is one area (of a few) where my lack of experience is letting me down.

Being a former graphic designer of the old skool (pre-computer age of the drawing board) the subject of website design has really caught my imagination. So I'm hoping I can learn and improve.

Thanks again for your help and hope to speak to you again soon,

Martin Underwood.

Oh and P.S... is there any way I can compress the width between lines of text because sometimes when I start a new line the gap looks too big and it feels like I'm jumping 1.5 or 2 lines instead of the one.
Photo of Andi North, Mangopear Media

Andi North, Mangopear Media

  • 782 Posts
  • 111 Reply Likes
Hi Martin,

I thought I would amend the line-height issue you have. Add this to the page:

<!---

body, th, td, input, textarea
{
line-height: 50%;
}
</style>

--->

Then, add the following to the table suggestion below (replacing the certain section below):

<!---

<style type="text/css">
.tablefont {
font-family: "Trebuchet MS", Arial, Helvetica, sans-serif;
line-height: 100%;
}

Andi

--->