Phantom Boxes

  • 1
  • Problem
  • Updated 6 years ago
  • In Progress
On a lot of my pages I have a ghost or phantom grey box overlapping a small area of the page, usually over text, it doesn't appear when I publish to the web only when editing the page. If any text lies within the phantom box I cannot directly edit the text and have to use the arrow keys to get to the text I wish to edit. It is a little difficult to explain I have an image of said phantom here.
Photo of Howie

Howie

  • 22 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 1
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Hi Howie,

That is strange.

May I ask which browser you are using ? Chrome?
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Sorry. I can see that it's FireFox. The only thing I can suggest is to clear your browser cache and if you have a lot of tabs open or another copy of FF running, see if you can close as many as possible and see if this takes away the problem??
Photo of Laura Thomas

Laura Thomas, Social Media Coordinator

  • 4536 Posts
  • 211 Reply Likes
Hi Howie,

It looks like you have added some custom code that may be causing that. Alternately it could be related to a browser add-on or toolbar. Please continue with Gop's advice and if you are still having trouble, reply with the page URLS you see this one and we will take a look at your account with your permission.
Photo of Philip Taylor

Philip Taylor

  • 355 Posts
  • 66 Reply Likes
Not sure, but I've had a similar effect when I place something on a page that's not in a "div" while an item above it is in a div or other block item.
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Philip

I have checked your Sitebuilder, and this is what I see when I open the page you posted above:



I'm not getting the "ghost" box, and I can't see anything else funny. I would now go for the browser add-on option. Unfortunately the only way to find out which add-on is causing this is to deinstall one by one, and check when you don't see the box any more.

If you'd like to do that, please keep us updated on which add-on was the problem. Thanks.
Photo of Howie

Howie

  • 22 Posts
  • 0 Reply Likes
Thanks for all your help guys, the strangest thing has happened, the phantom boxes that I have had for months and months and months, which exist in both IE and FF new release versions and previous versions, with the browsers cache full and emptied has annoyingly turned into white out boxes......

I have to ask is this something you guys have done by trying to alter something on my behalf, because I cant see what text is hidden, and I am worried that if I publish any updates the white boxes will be on the site.

Sometimes I guess saying nothing is the best course becuase the phantom boxes were slightly annoying and nothing major but this white box will be an eyesore.

I havent had chance to turn off the add-ons yet I will do this the moment I get a free 5 minutes but wanted to:
A: Thank you.
B:Update you.
Photo of Howie

Howie

  • 22 Posts
  • 0 Reply Likes
Advice: Am I doing this right. I have been going into the "manage add-ons" section of IE disabling 1 at a time the enabled add-ons, saving it then refreshing the page.... is that right or do i have to shut down the browser or reboot the computer between enabling and disabling... Ta

By the way nothing I have disabled has removed the now white boxes in IE
Photo of Howie

Howie

  • 22 Posts
  • 0 Reply Likes
Ok I have enabled/disabled add-ons in both IE and FF and doesnt seem to make any difference, the only good news is that the phantom boxes have returned and the white boxes have gone.... its such a drama...
Photo of Philip Taylor

Philip Taylor

  • 355 Posts
  • 66 Reply Likes
To put your mind at ease, all your pages are showing fine, without "ghost boxes" or "white boxes" in IE and Firefox, at least.
Don't know if it's significant or not, but in you Home page in div id 1716_sys_text your background-color definition is not complete (no color specified).