PHP errors galore - please help

  • 1
  • Question
  • Updated 10 years ago
  • Answered
Hi
I have spent a few months creating my site on SynthaSite and now I have finally uploaded it to my new hosting provider and it doesn't work.

the first error I got was
Parse error: syntax error, unexpected '&', expecting T_VARIABLE or '$' in /clientdata/n5200-2-dynamic/d/i/digitalmarketinglab.com.au/www/index.php on line 31

So what I did was delete the & sign,
then it came up with another error stating line 17 also had a programming issue related to the user session,

so I tried to fix that then it came up with another error of;

Parse error: syntax error, unexpected T_STRING in /clientdata/n5200-2-dynamic/d/i/digitalmarketinglab.com.au/www/index.php on line 18

Why is the site coming up with so many errors?
Photo of teresa

teresa

  • 5 Posts
  • 0 Reply Likes
  • frustrated

Posted 10 years ago

  • 1
Photo of Monique

Monique, VP of Customer Support

  • 6294 Posts
  • 446 Reply Likes
Hi teresa
Can you check that your host is running PHP version 5.2x or higher?

If not, that would explain the error.
Photo of teresa

teresa

  • 5 Posts
  • 0 Reply Likes
Hi Monique,
Does this problem relate to my last error - or all of them?
Photo of Monique

Monique, VP of Customer Support

  • 6294 Posts
  • 446 Reply Likes
It is difficult for us to debug as we do not have access to your hosting environment. Your hosting service needs to assist you. However, the first place to start is with checking the PHP version.
Photo of teresa

teresa

  • 5 Posts
  • 0 Reply Likes
Hi Monique,
It is running 5.2 - but this is an obvious coding issue on the site - because the error message stipulates that there is a coding error.
Is there nothing more that can be done on this?
Photo of Monique

Monique, VP of Customer Support

  • 6294 Posts
  • 446 Reply Likes
You could try and publish your site to our servers as a test run to make sure everything is working correctly from our side. If it isn't we can help you look at the code on your site.

If your site does run on our servers, but not in the environment of your hosting provider they need to help you. We do not have access to their servers so it would be impossible for us to debug. I do know that a common cause for parse errors is an out of date PHP version.

Please try publishing your site through SynthaSite and let me know the result. You can always unpublish it again if you wish.
Photo of teresa

teresa

  • 5 Posts
  • 0 Reply Likes
fixed it myself
your site has 2 coding errors in it, these can easily be fixed - it has got nothing to do with the hosting provider.

If anyone needs help on the above please let me know
Photo of fred29

fred29

  • 1 Post
  • 0 Reply Likes
Hello, I have the same probleme, i'm trying to go in the code by myself, but right now i dont find the solution,

could you help me?