Pictures not loading quickly or at all on website.

  • 1
  • Problem
  • Updated 7 years ago
  • Solved
My website pages load very slowing mainly the pictures are delayed in loading up. I often have to refresh the page to get them to load at all. One of the pages did not load at all even with a refresh, but then did once I closed out and reentered the site. Activity on all other internet sites today is fast so it seems like a processing issue at yola. Anyone else having this problem?
Photo of Cameron

Cameron

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 7 years ago

  • 1
Photo of darrensmith

darrensmith

  • 17 Posts
  • 0 Reply Likes
can you post a link to the site?
Photo of Cameron

Cameron

  • 2 Posts
  • 0 Reply Likes
Photo of darrensmith

darrensmith

  • 17 Posts
  • 0 Reply Likes
all loading quick/ instantly at my end cool kites in the u tube clips
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Hi Cameron,

There are variations in loading times, due to whatever. I have noticed this on occasions but they always come good sometime later. Yolasite sub-domains can be affected noticeably but once again these tend to correct in time.
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Cameron

I can confirm Darren that your website also loads quickly on my end. Gop is right that there can be various reasons why your website loads slowly.

I have checked the size of the pictures you uploaded to your Yola account, and every picture is fine except for the one you added to your Contact us page (some MB). The larger picture sizes are, the longer it will take to load. We recommend to use pictures of between 20 and 100 KB per picture.

Can you please check if your website still loads slowly when you use a different browser?

You can also try these basic trouble-shooting steps:
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Cameron,

while checking your site, I also noticed that you pre-filled the fields of your contact form of your Contact us page. This can be confusing for users who you want to fill in your form because not everyone knows that the pre-fills will disappear when they click into the fields. I'd recommend you to not pre-fill your fields at all.

Here is how to change it:
  1. Log into the Sitebuilder and go to the page that has your form.

  2. Click "Edit" on the Form Widget toolbar.

  3. Delete any pre-filled information from your form fields.

  4. Republish your site.