Please Help! How to get rid of underlines on page-linked text.

  • 2
  • Problem
  • Updated 5 years ago
  • Solved
Hi, i need help to somehow get rid of the underline under the page-linked text.
It looks ten times more professional with out it underlined (as it was before linking it to a page) i am just using yola free and i'm not super experienced! any and all help is appreciated! thanks!
Photo of braeden

braeden

  • 7 Posts
  • 0 Reply Likes
  • frustrated

Posted 6 years ago

  • 2
Photo of Nathan

Nathan, Champion

  • 3739 Posts
  • 307 Reply Likes
Hello Braeden,

Can you post your website's URL (address) so I can get the class name and/or id of the link's parent element and I'll give you some CSS to insert into an HTML widget that will remove the underline from the links.

Nathan
Photo of braeden

braeden

  • 7 Posts
  • 0 Reply Likes
www.bossplumbing.ca

Thanks alot! Well appreciated!
Photo of Nathan

Nathan, Champion

  • 3739 Posts
  • 307 Reply Likes
Okay, I got your code done :)

Since you don't have Yola Silver (on Yola Silver there is a CSS editor that will apply to all pages on the site), just put this into an HTML widget (which is under the Basic category on the widget sidebar) on each page of your site that you want the underlining of those links gone:


<style type="text/css">
#I19 a {
text-decoration: none !important;
}
</style>



I hope this helps.
Photo of braeden

braeden

  • 7 Posts
  • 0 Reply Likes
sweet thanks! Do i put it under the already made html or on top of?
Photo of braeden

braeden

  • 7 Posts
  • 0 Reply Likes
nvm! it works! Thanks alot! your a life saver!
Photo of Nathan

Nathan, Champion

  • 3739 Posts
  • 307 Reply Likes
No problem. I'm glad it helped!
Photo of braeden

braeden

  • 7 Posts
  • 0 Reply Likes
Oh wait!? this code only worked on the index page!? Should it work on all of them? Thanks
Photo of Nathan

Nathan, Champion

  • 3739 Posts
  • 307 Reply Likes
Yeah, as I mentioned above, the only way to do it is to add it to each page. I'm sorry that there isn't an easier way to do it.
Photo of braeden

braeden

  • 7 Posts
  • 0 Reply Likes
Yup thats fine, i did add it to each page, still only works on index...... the updated version is published to the web if you want to take a look.
Not sure why it wont work :(
Photo of Nathan

Nathan, Champion

  • 3739 Posts
  • 307 Reply Likes
Oh, the ID is different on each page. I wish the ID was the same on each page, but we have no control over that because the system gives each widget a random ID.

I'll just show you how to get the ID.

1) Go to the page's preview OR the live page.
2) Right click and choose 'view source'.
3) Search for "!important" (Ctrl+F) in the source. There should only be one match. Near that match is an id, similar to "I19" but not exactly (it varies from page to page).
4) Copy that ID and change it in the code I gave you, but only for that one page. The part that you change is in bold below:

<style type="text/css">
#I19 a {
text-decoration: none !important;
}
</style>

Here's a little screen recording that I did demonstrating how to do this, it's fairly simple: http://screencast.com/t/UlZepXTHsV

You can do this in the preview of your site as well, not just the live page.

If any of this is confusing to you, please let me know.
Photo of braeden

braeden

  • 7 Posts
  • 0 Reply Likes
Cool, tryed that on a page and seemed to work! not quite sure how to search like you did but ill make it work! Thanks!
Photo of Nathan

Nathan, Champion

  • 3739 Posts
  • 307 Reply Likes
I'm glad it worked! Feel free to let us know if you have any more questions.
Photo of Sarah White

Sarah White

  • 17 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled
Is it possible to delete the underline in text links?.
Photo of Laura Thomas

Laura Thomas, Social Media Coordinator

  • 4536 Posts
  • 211 Reply Likes
Hi Sarah,

It is possible but requires some CSS code. A sample code strand is included above.
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Hi Sarah,

Unfortunately I can't see your original posting as it has been deleted so I'll answer this presuming you wish to remove all underlining from all text links(?)

If you have Silver or Gold hosting then add this code to your Site CSS:

a:link {
text-decoration: none;
color: #hex code;
}

You can omit the color:#hex code if you wish your link text to remain the same colour as non-linked. If you wish to enhance the links by using a specific color then you would add the color specific hex code by referencing with a color code chart, there.

If you have free or Bronze hosting then you can do this by adding the code to each page of your site in an HTML widget:
<style type="text/css">
a:link {
text-decoration: none;
color: #hex code;
}
</style>

Once again you can add specific color text for links as described for the sitewide CSS
Photo of Sarah White

Sarah White

  • 17 Posts
  • 0 Reply Likes
Hi all,
Thanks for your responses. I tried putting in the html widget with the code suggested above.

Unfortunately, it only worked for two of the words that I made links for. The other two (Home to index page, and Contact to contact page) have no underline beneath them, but they also don't work as links for some reason.

I tried to preview the site, view the page source and find "important" as instructed, in order to swap code, but that word was not found, only "import" came up. Is this what I should be looking for?

I do not have Yola silver/gold so I need to find a way to do this under the free Yola site. I do not have any issues with changing color because it does not seem to change when I link the words.

Thank you so much for any help!
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Hi Sarah,

You will need to remove the code you placed and replace it with
<style type="text/css">
a:link {
text-decoration: none;
}
</style>


This allows you to place CSS into Free or Bronze subscriptions whereas the snippet you placed will only work for Silver/Gold at a specific location.
Photo of Sarah White

Sarah White

  • 17 Posts
  • 0 Reply Likes
Thank you for your response. It doesn't seem to be working for some reason. Now the two that were working before still work, but there is a line underneath them. The two that weren't working before are still not working.

I put the code into an html widget, saved it and previewed it. Is this all correct?

Not sure what to try next, any suggestions would be appreciated.

Thank you!
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Hi,

Did you remove the earlier code?

Can you also let us know the website and can check the code on your site

You can also try:
<style type="text/css">
a {
text-decoration: none;
}
</style>
Photo of Sarah White

Sarah White

  • 17 Posts
  • 0 Reply Likes
Gop-

Sorry for the confusion. The code you suggested I replace it with is actually the code I have already tried. I had trouble getting some links to stick to two of the first words on the top of my website, but I just got them to work. So now I have all the links working, but still the underline beneath them. With the html code above in a widget.
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
If you can let us know the published site address then we can look at this with you.
Photo of Sarah White

Sarah White

  • 17 Posts
  • 0 Reply Likes
Of course! Here it is: http://dominikasmolinski.yolasite.com/

Thank you so much for your time.
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Add this to an HTML widget and see how it goes.
<style type="text/css">
.sys_txt a:link {
text-decoration:none;
color: #333333;
}
.sys_txt a:visited {
text-decoration:none

}
.sys_txt a:hover {
text-decoration:none
color: #000000;

}
</style>


Items 3 and 4 of your menu are a bit strange . I think this may be in the text set up of the page titles and look like a specific text underline(?). If this is the case then try and edit the page name text in your page manager without an underline.
Photo of Sarah White

Sarah White

  • 17 Posts
  • 0 Reply Likes
Cleared my browser. Still happens. When I scroll over the upload images buttons it doesn't let me click on it for some reason. I can go to browse uploaded images but whenever I try to upload it doesn't let me click on the button.
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Hi Sarah,

What browser are you using?
Photo of Sarah White

Sarah White

  • 17 Posts
  • 0 Reply Likes
Firefox 19.0.2
I don't remember every having problems with Firefox and uploading images on Yola but I have updated it since then and maybe there's a new feature that's making things act weird in Yola? Do you think that's what it is?
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
I think that there has been some alteration to the process of adding images with the File Manager. You need to click "add a File" button and this queues a file to upload, then you click on "upload Files". I do notice that the "add a file" button doesn't cause the cursor to change to an executive icon but rather remains as a text icon but it still seems to work.
Photo of Sarah White

Sarah White

  • 17 Posts
  • 0 Reply Likes
For some reason Firefox still doesn't work, but I was successful in Safari so I will just use that browser instead, thank you!
Photo of Saskia

Saskia

  • 110 Posts
  • 11 Reply Likes
Hey hello!

Having the same problem and by the looks of it you need a special personalized code to be able to get rid of the underline.

The website im currently building is www.tqtours.yolasite.com and i am a bronze member

I'd like to get rid of the lines under australia, south africa and england

Looking forward to hearing from someone who actualy understands CSS!

Thanks a million!

Saskia
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Saskia

You can remove the underline by editing the Site CSS. This ability is a Yola Silver feature. Are you ready for an upgrade? If so, I'll be happy to provide you with the necessary code.
Photo of Saskia

Saskia

  • 110 Posts
  • 11 Reply Likes
Thank you Stefan!

I have no clue why i decided to go for Yola bronze instead of Yola silver, seeing the difference is only $6 and you get more options!!

Anyway I have made 2 websites in my account www.discoverycoasttheatregroup.com and www.tqtours.yolasite.com which still have to be linked to another domain (the third one is just for a dream i have ;)). The first one is for a non for profit theatre group of which i am the secretary and the other i've made for a friend (business page).

I have asked my friend if she wants to update to Yola Silver as the theatre group is happy with a Bronze subscription. I will get back to you as soon as i hear from her - which wont be long.

Now, i believe i have just recently paid the account for another year Yola Bronze (well a few months back). If i want to upgrade to Silver how much do i have to pay extra and untill when would the Yola Silver be valid to??

Thanks again for your help!!

Cheers,
Saskia
Photo of Saskia

Saskia

  • 110 Posts
  • 11 Reply Likes
Hello again Stefan,

My friend was online so while writing the message above to you she already responded to me. Yes, let's upgrade to Yola Silver :)

If you may please forward an invoice and provide me with the code?

Thank you!
Saskia
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Saskia

If you compare monthly costs for Yola Bronze and Yola Silver, there is a difference of USD5.00 between the two packages.

When you upgrade from Yola Bronze to Yola Silver and you choose annual payment, you will get a 30% discount on your purchase in order to make up for what you've already paid for your Yola Bronze subscription. The expiry/due date of your new Yola Silver package will change according to the date of your upgrade, so you will get a full year of Yola Silver at 30% of the normal annual price.

I can see in our system that you've already made an attempt to upgrade, but it wasn't finished? Please try again, and after the upgrade has been done successfully, I'll be able to provide you with the CSS code you need. Let me know if you have any trouble with upgrading or on Check-out.
Photo of Saskia

Saskia

  • 110 Posts
  • 11 Reply Likes
Hi Stefan,

I've been a little stupid replying to the email i got in my email inbox which was to a no-reply address. No wonder i didn't hear back from you!! Ive done this twice now...im not even blonde but sure hope its enough to remember for next time to jump to this forum instead of hitting the reply button :P

Anyway my reply:

---

Hello again :)

I've just updated to Yola Silver :) --- well this was on 12/06/13

My receipt says that the annual payment is $68.95 which is the same i paid now. Not sure if i've been given the 30% discount??

Also: i would like to delete my payment details as i don't like automatic payment .. (it is not me but the theatre group and my friend that will share the costs). When i try to delete my details it says i'll have to replace it with other cc details...Is it possible to just get a reminder that my subscription is almost due - lets say a month in advance - and then just pay manually? Without having my personal credit card details on file?

Thanking you very much for your help and looking forward to the code :)

Cheers!

---

I am also hoping you might be able to help me with the following problem i have:

My website is not showing the same in IE as in Firefox (Firefox shows it correct). Im not sure what i can do to make the site look the way i want to. If i make changes to the site in IE it looks weird in Firefox and visa versa...

Before redirecting the site to the correct domain name and going live i would really like to have everything alligned in IE as many people use this browser. It would be very much appreciated if you could have a look at the site www.tqtours.yolasite.com and see if it is something i can easily fix or if i just have to exept the way it is with different browsers...

Thanks a lot for your time and energy put into answering my questions!!

Saskia
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Saskia

I see that you've posted your additional question on IE on our forum separately, which was the best thing to do, thank you. Your question will then be answered there.

With regard to your first message: Yes, the amount you posted looks like the discount off the normal price of USD99.95. However, automatic billing is standard with Yola (as it is with many other providers of the same business). You can cancel auto-renewal at any time by sending us an e-mail, using our Contact Support Form. When your subscriptions reach their expiry date, you will get e-mail reminders from us and be able to renew manually. After each manual renewal, auto-renewal will be re-enabled, so you will need to cancel it via e-mail for every billing cycle if you don't want auto-billing. Yola decided to introduce auto-renewal because many users forgot to renew their subscriptions inadvertently and lost their domains.

I will provide you with the code in another reply on this thread.
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
In order to remove the underlining of your menu links on mouse-over, please follow these steps:
  1. Open your website in the Yola Sitebuilder.

  2. Click on the "Site" tab.

  3. Click on "Content".

  4. Click on "Site CSS".

  5. Copy this code completely:
    .sys_navigation ul li a:hover {
    text-decoration: none;
    }

  6. Paste the code to the empty Overrides box of the Site CSS Editor.

  7. On the right-hand side, click on the preview tab and and check if your change works.

  8. Click on the "OK" button in the bottom right corner to save your changes.

  9. Preview your page and check your changes again.

  10. Republish your website for your changes to become effective on your live site.
Photo of Saskia

Saskia

  • 110 Posts
  • 11 Reply Likes
Hello again Stefan,

Thank you for your quick response!

I totaly understand the reason behind Yola's automatic payment system, but am happy there is an alternative :) Can you advice me as to how far in advance - roughly - i will receive the reminder for payment?

In regards to the code...i've tried it but it doesn't seem to work. I've followed all the steps you mentioned above but the underlining under Australia/England and South Africa is still there...

Thanks again for your time!

Cheers,
Saskia

PS:
I'll have to re-read your response to the firefox/IE problem i am facing, just read it quickly this morning and it was a little confusing with all the abbreviations. But if i have any further questions i will respond in the correct thread ;)
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Saskia

You will get multiple e-mail reminders in intervals of 3 months, 2 months, 1 month, and then more frequently before expiry. Our reminder e-mails sometimes end up in Spam folders, so I'd suggest to make a note in your calendar 2.5 months or something prior to expiry and check your spam folders if you haven't received our reminders. Your packages will expiry on the exactly same date at the end of the billing cycle, so if you purchased a domain on 14 June 2013, it will expire on 14 June 2014 (provided it's a one-year subscription).

With regard to the code: That's strange because when I check it in your Yola account directly, it's working fine for me, and I no longer see underlines on hovering over your menu links. Maybe we're not on the same page? These are the links which I understood you want to edit:



These links do not show underlining any more for me. If it persists on your end, could you please try to clear your cache and cookies, and let me know if that helped?
Photo of Saskia

Saskia

  • 110 Posts
  • 11 Reply Likes
Gosh do you work 24/7? Men you're quick! Thanks :)

I will put a reminder in my phone and on my calendar so pretty sure i won't miss it, especially if i check my spam every now and again and get reminders from you guys so often, fantastic!

In regards to the links, nope... was talking about the home page.

So i assume thats the reason why they underlining is still there. Hopefully its not too much trouble to find another code for me?
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Saskia

Our normal response policy is 24 hours, so you've been lucky! :-)

OK, now I've got it, so you'd like to change the behaviour of links added to Text Widgets. That's easy to edit. Please add this code to the same place as mentioned above:
a:link {

text-decoration: none;
}

Please note that this will remove underlining from any link added to a Text Widget. If you'd like to apply the removal of underlining just to these links above, let me know and I can show you how to do it. It's easier if you add it to your Custom CSS though, and apply it to all links of your website added to the body area of your pages.

If you don't want underlining to be removed from your navigation menu links, just delete the code provided by me above from your Site CSS Editor.

By the way, did you add that Text Widget text by copy/pasting from MS Word or something? Just want to make sure you know that you shouldn't copy/paste text from programmes like Word directly as they have hidden formatting which can mess with your website. You can copy text to a programme like notepad first, and then copy it again to paste it into a Text Widget.
Photo of Saskia

Saskia

  • 110 Posts
  • 11 Reply Likes
Yay, lucky me indeed :)

Even if i have to wait a day or so, im really impressed with the way Yola works and looove editing with all the easy tutorials! Wouldn't mind becoming part of the family so if there's a job somewhere that needs filling let me know ;) Haha might need to do a bunch of courses first if i cant even answer my own question :P

Issue is solved! Thanks for the code :) No i didn't copy and paste from word. But the text was provided by me by a girlfriend - for whom i make the site - in an email. I guess she used Word to write it and that would still leave the hidden formatting. I will keep it in mind to use wordpad next time before i add and edit the text on the site!

Thanks again for all your help and have a nice rest of your evening!

Cheers,
Saskia
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
It's a pleasure, Saskia, thank you for you compliment! We're indeed hiring at the moment, but it's in San Francisco, and the jobs refer to engineering.

Enjoy Yola, and let us know if you need more assistance!
Photo of Saskia

Saskia

  • 110 Posts
  • 11 Reply Likes
Yeah, not for me an engineering job and defintely not in North America, im happy here in Australia ;) I think ive taken up enough of your tme for now so leaving you alone for bit! Take care :)