Prices not showing correctly on online store

  • 1
  • Question
  • Updated 5 years ago
  • Answered
the zero's aren't showing in my prices on the online store how do I correct this please?
Photo of Sue

Sue

  • 58 Posts
  • 0 Reply Likes
  • frustrated

Posted 5 years ago

  • 1
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Hi Sue,

Can you explain a little on how they are not displaying properly?

If this is the trailing zeros after the . then this can be set in the Control Panel.
Photo of Sue

Sue

  • 58 Posts
  • 0 Reply Likes
Hi Gop

Ah I think i've seen that I'll take a look thanks again

Sue
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
System Settings > General > Formats & Units >
{Hide trailing zeros in fractional part [ Disable ]}
Photo of Sue

Sue

  • 58 Posts
  • 0 Reply Likes
Hi Gop

Is this the advanced opions, system settings, Formats and Units, Currency?
If so the hide trailing zero's in fractional parts is disabled but the trailing zero's don't show on the online store £4.00 just shows as £4 on my list and on the online store itself just 4 shows???

Sue
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Hi Sue,

Did you enter the price as x.00 GBP's for a product?
For products with non-zero pence , do they show?
Photo of Sue

Sue

  • 58 Posts
  • 0 Reply Likes
Hi Gop

Yes the price is entered as x.00 for each product but is set up as pounds sterling
None of the zero pence show at all
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
OK. Try this. Toggle the disable/enable and see what happens?
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Photo of Sue

Sue

  • 58 Posts
  • 0 Reply Likes
No still not working
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
How about the currency display format? Try changing that?

If that doesn't work I'll do a search for it.
Photo of Sue

Sue

  • 58 Posts
  • 0 Reply Likes
No thats not working Gop, it's appears to save but then it's not changing anything
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
OK. Not saving? I would try a cache clear then. Sounds as if it has choked up?
Photo of Sue

Sue

  • 58 Posts
  • 0 Reply Likes
Hi Gop

No that isn't working either
Photo of Sue

Sue

  • 58 Posts
  • 0 Reply Likes
Sorry Gop not tried the cache clear yet will do that now
Photo of Sue

Sue

  • 58 Posts
  • 0 Reply Likes
Hi Gop

Cleared cache and cookies but it's not made any difference to the zero's showing

Sue
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Hi Sue,

I have looked through the Ecwid forums and Knowledge Base and we've done everything that they suggest.

Trying not to flog a dead horse but give it one more go . Make sure that the Enabled word is highlighted in blue and there is no green arrow tick beside the option of trailing zeros.

If that doesn't work then I suspect it is either something very obvious that I'm overlooking or there is an issue with the module. I'm happy to have a look at your sitebuilder Online Store and if you wish me to look at it this way just send me an email to gop@designscent.com.
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
One more thing before we become dejected and despondent. Can you update your Flash and Java.
Photo of Sue

Sue

  • 58 Posts
  • 0 Reply Likes
Ok checked the updates.

I like the flogging the dead horse pic lol --- the disabled word is not highlighted in blue it is greyed out (enable) is in blue - no green tick

If i click enable i have a green tick, enable is in green and then (disable) is in blue
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
It should be the as you described in the first sentence.

Did you get a chance to update your Flash and Java? (longshot!)
Photo of Sue

Sue

  • 58 Posts
  • 0 Reply Likes
Yes Flash and Java are updated fully
Photo of Sue

Sue

  • 58 Posts
  • 0 Reply Likes
Hi Gop

The trailing zero's in the prices are showing when i go to edit categories but not on the online store widget when i put it on the web page or on the list of products available

Sue
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
See above comment.

Have you published with your store as yet? It would be good for me to see the published appearance.
Photo of Sue

Sue

  • 58 Posts
  • 0 Reply Likes
I havent saved the online store to my website yet as the sandbox is not complete to enable me to check the PayPal
Photo of Sue

Sue

  • 58 Posts
  • 0 Reply Likes
Hi Gop

If i publish the online store can i hide it from the public or do i have to sort out my PayPal first?
Photo of Sue

Sue

  • 58 Posts
  • 0 Reply Likes
Ok then Gop i'll do that then you can have a look thankyou
Photo of Sue

Sue

  • 58 Posts
  • 0 Reply Likes
Right Gop I've done that, strangely when you click on the pictures the zero's do show but not on the main screen or on my listing, maybe that's just how it is anyway, let me know what you think please

Kind regards Sue
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Hi Sue,

Noticed that you have a duplicate category of Door Plaques. You can delete one of these and I think it will be fine.
Photo of Sue

Sue

  • 58 Posts
  • 0 Reply Likes
Thankyou Gop
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
It's looking very nice Sue. just spent a couple of minutes having a look at your site and store and they come through very nicely.

if you need any help tweaking the store please let me know. Trust your working through the sandbox and see that it all works out.

I made a selection and went to checkout and it advised me correctly that it doesn't ship to Thailand. It picked the destination from my IP address so this is working very well.

Gop.
Photo of Sue

Sue

  • 58 Posts
  • 0 Reply Likes
Thanks for looking at that Gop i'm going to look shortly at going live with PayPal
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
That's really exciting Sue. can't wait to hear your response to its operation in the real world and I wish you all the very best with your business.

Your products are very nice so I believe that yours will be a successful endeavour.