Problem with moving widgets

  • 1
  • Question
  • Updated 10 years ago
  • Answered
I cannot move widgets properly. First of all - please do not explain me procedure again. I know it.
Now, what the matter is. I had moved one of text widgets to other place. It looked OK in the editor. But when I opened "preview", everything in the column changed its place. I came back to the editor and tried to put widgets back to their places. But I was not able to. When I dragged some widget, an icon didn't disapear. When I clicked on it, given widget was in on the same wrong place.
It happens quite often, that moving one thing, causes other elements - in completely different place - change their location too.
Now my site is a mess.
Photo of Jack

Jack

  • 81 Posts
  • 1 Reply Like
  • frustrated

Posted 10 years ago

  • 1
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Hi Jack

I'm sorry that you're frustrated. I am wondering if you're saving your work before you preview? Also, can you try clearing your cache in your browser and then re-logging back in?

Lastly, what browser are you using? Yola works best with Firefox. If you have not downloaded this, I recommend that you do. It's free! You can download from here: http://www.mozilla.com/en-US/firefox/...

Let us know if this resolves the problem.
Photo of Kershnee

Kershnee

  • 2087 Posts
  • 152 Reply Likes
Hi Jack,

I am sorry you are feeling frustrated. Can you please try out the suggestions given by Littleus. If you are still having no joy with this, please let us know.

Thanks Littleus for answering.
Photo of Jack

Jack

  • 81 Posts
  • 1 Reply Like
Yes, I am saving. However sometimes there is no point to save if there is nothing to save - widget is not moved. Instead of that an icon stays in the place where I dragged it.
I use Internet Explorer 8 as well as Firefox.
Photo of Jack

Jack

  • 81 Posts
  • 1 Reply Like
I followed all those advices. Cleared cache, used Firefox, re-logged several times, restarted computer... It has not helped.
I noticed somethig new. I can move widgets from right to left column, but cannot move them properly within right column.
Photo of Donald

Donald

  • 2991 Posts
  • 37 Reply Likes
Hi Jack.

Are you using Kontera at all?
Photo of Donald

Donald

  • 2991 Posts
  • 37 Reply Likes
I had the problem a couple days ago when I updated every page on my site that the first body text widget of every page moved itself above site search, get clicky, google analytics, and rate this article without me telling it to do that.

Anyways, the thing with kontera is that if you use it, you can't move any widgets underneath the kontera html. Instead, you would have to delete the kontera widget, refresh the page, save the page, then move your widgets, then put kontera back on the page.
Photo of Donald

Donald

  • 2991 Posts
  • 37 Reply Likes
Jack...

If you can move them from right to left column, can't move them properly in right column but you CAN move them properly in left column... then it is probably DEFINATELY a defective widget or html within the right column.
Photo of Jack

Jack

  • 81 Posts
  • 1 Reply Like
HI
I don't use any Kontera. What is it actually?
Yes I suspected ther is some defective widget or html. But how can I find out which one it is?
Photo of Sanja

Sanja, Official Rep

  • 10698 Posts
  • 495 Reply Likes
Hi Jack

I'm sorry that the above suggestions did not clear up the problems. This may indicate that there is a bad code. The only way to find out which one it is, is to systematically remove each one and see if it makes a difference. I would suggest doing a "save page as", under your save button - give the page a new name. This will replicate your page entirely. Then, on your new page, try removing one widget at a time and see how that affects your site. This way, you can always return to the original page.
Photo of Kershnee

Kershnee

  • 2087 Posts
  • 152 Reply Likes
Hi Jack,

Can you please email support@yola.com and we can take it from there.