Problems with description editor in online store!

  • 1
  • Question
  • Updated 7 years ago
  • Answered
no description editor in online store?.....I have now been messing with this for 3 days solid and Im going nuts! The editor has appeared at random 3 times only, and I managed to enter a product description. When I log out and go back into this everything has changed to HTML format which is impossible to edit......
Photo of Val Hunter

Val Hunter

  • 2 Posts
  • 0 Reply Likes
  • ready for a refund!

Posted 7 years ago

  • 1
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Val

Can you please let us know what operating system and browser (including version) you use? Thanks.
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Hi Val,

Is your description editor opening with the "HTML Source Editor" ?

If so just close this by clicking on the X at the top right of that modal window. You should now see plain formatted text in the Catalog<General window. In here you can type plain text.
Photo of Val Hunter

Val Hunter

  • 2 Posts
  • 0 Reply Likes
Thanks for your replies

Stefan, I have Windows 7 and use internet explorer 7. Hope you can give me some help with this? Im no computer wiz and have gone through all the ecwid tutorials and I cannot fathom this out.

Gop, There is no X there, the editor is just missing! I am able to type in the box, just have no editing functions at all so cannot sort a proper layout for my items. I keep logging out and in, and 3 times now it has appeared at random ( the editor) I did therefore manage to edit some text, saved it to preview the item, then when I went back in the editor was gone again, and all text changed to HTML format. I cannot understand why its appeared a few times but mostly not.

Val
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Thanks Val for getting back with this info.

Can you get into the Product window? Either through Add/Edit products in the Online Store or by going through Advanced Options? The other way is through the System Settings>Catalog. They all take you to the same place but just slightly different routes.

I understand what you are saying because when i go through this process it momentarily flashes the HTML code for the product description but continues on to plain text which is where it should end up. It sounds that your process halts at that point mid-way.

I have no idea if this is a Browser related issue but you may like to try to clear your browser cache and if that doesn't work try using Chrome or FireFox as your editing browser. I don't have IE9 as I use Windows XP, so I can't check that out for you specifically and I don't see the issue with IE8. There were previously reported issues with IE9 and Ecwid but these have been attended to by Ecwid some months ago and I can't see any further issues reported with IE9 so I am at a loss to give you hard facts on this. Is there anything that you would like me to do that may possibly help Val?
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Val,

May I ask if previously you have copied and pasted description text of your product(s) from another source like another website or from a wordprocessed file? I'm just wondering if there is some invisible and embedded, extraneous format code in a description file that has caused this issue?
Photo of Justine

Justine

  • 751 Posts
  • 45 Reply Likes
Hi Val,

Could you let us know whether you've been able to resolve the problem using Gop's suggestions? We'd like to make sure that your online store is working perfectly!