Problems with sitebuilder and images! PLEASE help!

  • 1
  • Problem
  • Updated 5 years ago
  • Acknowledged
Hello there! I am having some trouble with the sitebuilder. I have an image that I resized to a new smaller size. I want to replace that image with an image that is the same exact scale, and I want it to be the same size as the image there now. So, I went to do what I would always do and click edit to edit the image and click the upload button to upload the new image and simply replace the one that is there. Everything seems to be working fine until I click the "Save" button to close the popup to edit the picture. Then, on the page in the sitebuilder, the image scales to its actual size. It never did this before. Also, when I try to upload a transparent image, your stupid "optimize image" feature is enabled automatically and it makes all of my transparent pngs not transparent, so once the image is uploaded I have to click edit and turn off optimization and upload the picture again.
Photo of Austin James

Austin James

  • 14 Posts
  • 0 Reply Likes
  • angry

Posted 5 years ago

  • 1
Photo of Gop


  • 7473 Posts
  • 2115 Reply Likes
Hello Austin,

You've done the investigation well and many agree with your observations.

To go one step further I think is your solution. Do all your image editing before uploading your image including setting the final dimensions. Keep the file size optimal for we-use say between 20 to 100 Kb per image and this depends on the final size.

If you do this then there is no loss of fidelity, colour or transparency. The inline editor is what causes the changes your see as you have noted so if you bypass the use of the editor completely you will see a perfect image displayed.

If you can use HTML to place your image then this is the ideal followed by the text widget image insertion and least reliable the image widget.

Aviary is the image editing facility used by Yola but at this time it seems that it is not a perfect marriage and reports are that it is still being improved.