Product weight incorrect

  • 1
  • Problem
  • Updated 6 years ago
  • Solved
This just started today..... I have products in my store with multiple "options". Within each option, it shows the weight always at 0 which I have never been able to change, but hasnt been a problem because in the store it defaults to the original weight I inputted on the main data screen.

However, today new products in the store are registering as having 0 weight. I have set the weight as I have all my other products and tried many times to edit the weight in the "options" screen, but nothing.

This will be troublesome when checking out because the shipping costs will be incorrect.
Photo of chrisdhassan

chrisdhassan

  • 61 Posts
  • 3 Reply Likes
  • confused

Posted 6 years ago

  • 1
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Hi Chris,

Hoping this will get you there:

Once you're in the Store:

Select Catalog→Products

In the list of products shown click on the product you wish to edit.

Then select General (not Options)

Add your weight

Save

If for some reason this is blocked, then I would clear your browser cache and re-try.

If this doesn't work then try an delete one of the products and re-add it with the weight included as the primary addition.

These latter opinions are simply trials and this isn't a known issue that I am aware of. Let us know if any of these work for you or not.

Gop.
Photo of chrisdhassan

chrisdhassan

  • 61 Posts
  • 3 Reply Likes
SUCCESS!

Hey Gop,

I have always entered in the general field first, the problem WAS that if the product had options, the options didnt have weight.

Yesterday it wouldnt let me edit it, but today it is.

I cleard out my cache before I tried again, so I cant say if it was just a bug or if it was the cookies. But it is working now, thank you!
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Good outcome.
Photo of chrisdhassan

chrisdhassan

  • 61 Posts
  • 3 Reply Likes
Uh oh....it looks like only about 75% of the time it is allowing me to make the change.....I can type in the weight under the option tab, but not all of them accept the change....
Photo of chrisdhassan

chrisdhassan

  • 61 Posts
  • 3 Reply Likes
For the first few options per product I can edit no problem, but when I get to the 3rd or 4th it will only allow me to enter whole numbers. I have shirts that weigh 0.3 kg, but it will only allow me to enter it as 1kg even though 0.3 was working just a moment ago....
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Please be sure to add the leading zero. this has been reported before when the leading zero has been dropped. Other than that I don't know.
Photo of chrisdhassan

chrisdhassan

  • 61 Posts
  • 3 Reply Likes
ya....Im doing that....
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Cleared your cache again?
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Chris,

is this working out for you now?

One thing that has come to mind is that Ecwid rolled out a new version of their store on Monday (V 11.0). It's always possible that there's a bug lurking with a big change in their systems as this one is.

If you are still seeing this problem then I would consider posting it as a bug report to Ecwid or through here. Through here would benefit Yola Online Store owners at the same time it's your choice.

The Ecwid bug report facility and trace is here: http://www.ecwid.com/bt/view_all_bug_...
Photo of chrisdhassan

chrisdhassan

  • 61 Posts
  • 3 Reply Likes
I was able to fix each product by using a combination of different computers and browsers. But I couldnt get everything correct with just one....We will see next time I need to update my products, but as of now, everything is good to go!
Photo of Gop

Gop

  • 7473 Posts
  • 2115 Reply Likes
Hi Chris,

Thanks for the follow up. I'm glad that you are functional with this. I hope you can work it out to be perfect. ideally it should perfect itself.