Share Button Not Aligning

  • 1
  • Question
  • Updated 7 years ago
  • Answered
Hi
I have a share button in an HTML widget on this page http://www.leathersolutions.org/
For some reason it will not align centre despite clicking the align centre button in the widget
It looks odd as the rest of the column is centre aligned, any help would be appreciated.
Photo of David

David

  • 465 Posts
  • 94 Reply Likes

Posted 7 years ago

  • 1
Photo of Ed-a-Torials @ Honey Bear Playhomes

Ed-a-Torials @ Honey Bear Playhomes, Champion

  • 2582 Posts
  • 279 Reply Likes
Hey David what you actually have is an Addthis button and not a Sharethis button... Easy mistake as their names are close. The Addthis button is well known to not obey the HTML widget's justification settings and thus you need to do a little code editing.

What you will want to do is go into your Addthis code and find the line which begins with something like this: (between the < and the > in the code...)

div class="addthis_toolbox addthis_default_style"

and replace it with this:

div class="addthis_toolbox addthis_default_style" style="float: right;"

That will effectively right justify that button...

Happy site building
Ed

You can find me with my head in the honey pot here...

Honey Bear Playhomes Tips and Favs in one place... A Honey bear Playhomes Tip ;)
Photo of Ed-a-Torials @ Honey Bear Playhomes

Ed-a-Torials @ Honey Bear Playhomes, Champion

  • 2582 Posts
  • 279 Reply Likes
Just read the "center alignment" part in your post... Let me figure out the code for that...
Photo of Brianna

Brianna

  • 2045 Posts
  • 92 Reply Likes
Hi David,

It looks like Ed is investigating into this for you. Thanks, Ed!
Photo of Ed-a-Torials @ Honey Bear Playhomes

Ed-a-Torials @ Honey Bear Playhomes, Champion

  • 2582 Posts
  • 279 Reply Likes
You are more than welcome... Anything to save the valuable time of the reps... Plus it was one of my tips in another thread so it was good that David brought it up so that I could edit that thread to include the center and right justifications.
Photo of Ed-a-Torials @ Honey Bear Playhomes

Ed-a-Torials @ Honey Bear Playhomes, Champion

  • 2582 Posts
  • 279 Reply Likes
Okay David...

I already changed the code to reflect your personal identifier so all you need to do is insert the following into an HTML widget...

sec... the forum is reading the code when it shouldnt. I am gonna have to put it on a page in my site so that you can copy it
Photo of Ed-a-Torials @ Honey Bear Playhomes

Ed-a-Torials @ Honey Bear Playhomes, Champion

  • 2582 Posts
  • 279 Reply Likes
There you go... I changed it around and your buttons are now centered. I added the code to my page so that you can see the way it will look.

http://www.honeybearplayhomes.com/add...
Photo of David

David

  • 465 Posts
  • 94 Reply Likes
Hi Ed
Thanks for your help, I've inserted the new code but unfortunately it hasn't worked, I also couldn't copy from your page and had to copy from the email notification.
Could you take another look
Thanks
Photo of Ed-a-Torials @ Honey Bear Playhomes

Ed-a-Torials @ Honey Bear Playhomes, Champion

  • 2582 Posts
  • 279 Reply Likes
I am sorry David but the problem must be on your end somewhere as I just copied directly from the page that I made with your code on it. There is no need to change the code to include your tracking info as I already took that from your website and added to the last line.

I have enclosed a video of what steps I took and as I am also using XP Pro and Firefox 3.6 (My analytics told me that they are the same as you) see no reason why any issues would arise. Tre bizarre...

http://www.screencast.com/users/honey...

I cannot add the code here in the forums either by means of the encoder or code reading blocks as the URLs contained in the code are read by the forums and I cannot stop that from happening.

Please try once more as I have done in the video and if that does not work I don't know what to tell you... Maybe try another browser perhaps...
Photo of Ed-a-Torials @ Honey Bear Playhomes

Ed-a-Torials @ Honey Bear Playhomes, Champion

  • 2582 Posts
  • 279 Reply Likes
Also, I checked your site's source and it still has the old code on it... Could it be that you failed to publish your site after the changes. ???
Photo of Nazlie

Nazlie

  • 1721 Posts
  • 51 Reply Likes
Hi David

It looks like Ed has given lots of help here. Thanks so much Ed, we appreciate it!

David, if you haven't yet published, you can check in the "Preview" to see what it looks like there before you publish. But let us know if you are still having trouble aligning the button.

Thank you
Nazlie
Photo of David

David

  • 465 Posts
  • 94 Reply Likes
Hi Ed & Nazlie
Apologies, I pasted the code and published, it didn't work so I pasted again and forgot to publish the second attempt, its now published and still left aligned

Ed, strange things indeed, I tried to copy from your page again and could only get the last line, I tried again and my PC froze. I've had no other issues elsewhere so I thought you might like to know.
Photo of Ed-a-Torials @ Honey Bear Playhomes

Ed-a-Torials @ Honey Bear Playhomes, Champion

  • 2582 Posts
  • 279 Reply Likes
Okay lets see if this one works...

I deleted everything but the code and example. That should be easier on your computer to handle with all that flash gone... Try going to the page again and try over...

http://www.honeybearplayhomes.com/add...
Photo of Ed-a-Torials @ Honey Bear Playhomes

Ed-a-Torials @ Honey Bear Playhomes, Champion

  • 2582 Posts
  • 279 Reply Likes
I still see the same original code on your index page... I think that you are adding the code to another page and not looking at that page to verify that it worked or not and that is your problem here. Happens to me still...

Photo of David

David

  • 465 Posts
  • 94 Reply Likes
Thanks Ed I was able to copy the code from your page and it now works OK on my site

I have one more question you may be able to help me with as I am not familiar with this button, on the live page the settings option is available for anyone to edit, this seems a bit odd to me as someone thinking its funny could remove all the options. Have you used this button before and came across this issue?

Thanks again for your help