Site dropped off Search Engines Previously Page 1

  • 1
  • Problem
  • Updated 5 years ago
  • Solved
Just some advice

I developed a site for a client on Yola called http://www.dbd-lean.com

He is a Consultant. Searching for "Lean consultant Burton on Trent" returned his site to near the top of page one and was there for months so quite happy with that. However. In the last week or so his site has disappeared. If I actually search for his site url it comes up but searching as before , or even with quite specific details on his site does not appear in search results.

So, the question is what could have caused this.

For info changes I have made that could have had an effect but it hasn't on any other sites I maintain.

Changes:
The client wanted his phone number on every page so I added this to the site heading for every page. (Since reversed it to see if that caused an issue)

I have added some Alt text to a few images

Created a new site in German http:/www.dbd-lean.de from the same account but no connection apart from a link on the German site back to the English version.

On Google Webmaster it says 15 pages submitted / 3 indexed but not sure what it was when doing well. I have manually submitted pages and these came back ok (I think)

There is one crawl error 404: http://www.dbd-lean.com/defaultsite.php not found
Not sure what this is as I haven't created that page

Anyway, just on here to see if any of the above could have caused the issues or advice on why this site suddenly dropped offf Bing & Google search results.

Thanks
Photo of openformula

openformula

  • 32 Posts
  • 1 Reply Like
  • confused

Posted 5 years ago

  • 1
Photo of Laura Thomas

Laura Thomas, Social Media Coordinator

  • 4536 Posts
  • 211 Reply Likes
Hi openformula,

I would like to ask both an SEO expert and our German translator to take a look and see if they can offer any insight into this. I do wonder if duplicate content could be a potential concern but I doubt it. In any case, they are likely to have more input than I can offer. Thanks for your patience while I have them review this.
Photo of openformula

openformula

  • 32 Posts
  • 1 Reply Like
Thanks Laura. The German site is only one of the changes I made as in the post so not sure which one caused the issue.
Photo of Mark N

Mark N

  • 466 Posts
  • 30 Reply Likes
Changing the alt text to photos can make a big difference in the search engines. I would suggest changing it back to how it was before (if you can remember how it was!).

I am on the first page for quite a number of searches on my four year old Yola site http://www.simplyeighties.com and altering the alt text on photos causes pages to drop down substantially in search rankings, so I now leave my old photos well alone unless a particular page is not ranking very highly.

I have some photos with no alt text (I never used to add any in the early days) and they are on the first page of google.

It's only a suggestion, and the alt text may not be the cause, but it's worth a try, at least.
Photo of openformula

openformula

  • 32 Posts
  • 1 Reply Like
Thanks Mark

I did add a couple of Alt texts to two images but all the rest had Alt Text. Also, I have done that before on other sites and had no adverse effect so not sure if that is the issue.

I did rename the site with Yola but that is an internal to Yola name and assume has no impact in SEO. I have renames another of my sites in Yola again without issue.

Thanks again
Photo of openformula

openformula

  • 32 Posts
  • 1 Reply Like
Well this is strange.

I checked yesterday and it is back on page one!

All I have done is take out the phone number details from the H! tag and a few days later is back to normal. This is strange as I do similar stuff on other sites and this works ok. Maybe it didn't like the +44 or brackets??