Sitewit slowing down my website - "waiting for connect.sitewit.com" and other similar problems.

  • 3
  • Problem
  • Updated 4 years ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

How to get rid of it? It looks like website is loading all the time and can't do it properly.
Photo of Jakub

Jakub

  • 3 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 3
Photo of Monique

Monique, VP of Customer Support

  • 6294 Posts
  • 446 Reply Likes
Hi Jakub

I am sorry about this. We are aware of the problem and from what we can tell it only affects your site when trying to load it in Chrome. Other browsers seem fine. Can you let us know if you are seeing this in any other browsers?

This is something we need to fix from our side and we will do so as soon as possible. My apologies for the inconvenience in the meantime.
Photo of Sue Heyer

Sue Heyer

  • 1 Post
  • 0 Reply Likes
I have the same problem as Jakub since today, am on Firefox, not Chrome. Also, www.adbayes.com seems to be causing the same problem since today. It's taking ages to open the forum that I am a member of. Very annoying!
Photo of Jakub

Jakub

  • 3 Posts
  • 0 Reply Likes
Hi Monique,

Thank you for your quick reply. That's correct, it only seems to be a problem when using Chrome.

It's just good to know, that it's not something wrong with my site and that you are aware of the issue.

Thanks
Photo of Andy

Andy

  • 2 Posts
  • 0 Reply Likes
My website is also having the exact problem! http://www.suitcase.hk/products-zh.php . Over the past 3 days, my site has been ridiculously slow. And I realized that there are 2 repeating scripts from Sitewit (I have never requested the service of it).

The later one will result to this link: http://connect.sitewit.com/js/8A4986C...

Because the sitewit key has been used twice for the same website. I have reported this problem to Yola and have yet heard back from them. I would like to cancel the service of sitewit and remove their script from my website! This shouldn't be mandatorily added to our site, it should be an option since we are all paying for our service at Yola. I am attaching the screen cature of my findings.





Photo of Andy

Andy

  • 2 Posts
  • 0 Reply Likes
Another comment:

Chrome has the most serious problem with the page that has javascript; My online store (Ewcid): http://www.suitcase.hk/products-zh.php and also my booking site: http://www.suitcase.hk/booking.php

Somehow, when Chrome try to load it, the javascript stuck when the page trying so hard to load the Sitewit script.

And, for the rest of the browser I tried: Internet Explorer and also Safari. Still the page would have an error of loading. But the javascript would somehow bypass it and still be able to load (unlike Chrome). Maybe its just different ways of Chrome and IE/Safari loading pages.

Please see the screen capture I took with Internet Explorer.

Photo of Pascal

Pascal

  • 3 Posts
  • 2 Reply Likes
Yes, same problem here. Glad to know you are working on it.

Can Yola advise us why this code is added to the shop system?

Thanks.

Pascal
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Official Response
Hello everybody

We've fixed the problem with loading Online Store in Chrome. Please clear your cache and cookies, and your Online Store should load as normal again.

Also, the rest of your site's pages should finish loading after a few seconds as usual.

That said, we'll keep looking into the cause of this issue to solve it on a deeper level it is based on. Thank you for bearing with us, and please let us know on this thread if you encounter any further problems with regard to this issue.
Photo of Peter Sauer

Peter Sauer

  • 150 Posts
  • 65 Reply Likes
I have been experiencing the same problem this week, my site normally loads in 2.1secs, when sitewit cant load it is taking 15 seconds. This means lost customers who leave because shopping cart won't load in time.
(Edited)
Photo of Saskia

Saskia

  • 110 Posts
  • 11 Reply Likes
Hello Peter,

I have also received your email regarding this issue. You can simply refer to my response there.

In an effort to minimize confusion, I will close this thread and will be happy to continue to assist you via email.