Skype widget says I'm offline - how do I make it live?

  • 3
  • Question
  • Updated 5 years ago
  • Answered
I've just installed a Skype widget but instead of the nice bue and green Skype me button, I've got a sad grey "I'm offline" button.

Please tell me how to make it live so that someone can Skype me directly from the page?
Photo of Susan Vial

Susan Vial

  • 1 Post
  • 0 Reply Likes
  • confused

Posted 8 years ago

  • 3
Photo of Kershnee


  • 2087 Posts
  • 152 Reply Likes
Hi Susan,

All you need to do is change some Skype settings. Here's how to do that:

1. Open Skype program.
2. Select Tools -> Options on Windows or select Preferences on Mac.
3. Select Privacy Settings.
4. Click the "Show Advanced Options" button.
5. Finally tick on the "Allow my status to be shown on the web" check button.
6. Click "Save" in the Options dialog to exit.

Let us know if this does not resolve your issue.
Photo of sipmarketinggroup


  • 1 Post
  • 0 Reply Likes
Photo of snooper


  • 3 Posts
  • 2 Reply Likes
I had the same problem. Above solution didn't work for me. Finally found that there is Javascript code embedded in the icon. You need to change your Flash Settings to allow Skype to access your website.

Go to the Global Security Settings of Flash:

Add two websites to the area and allow access:

Then click over to the last tab. The Peer-Assisted Networking Panel. Find the following websites in the list, and edit them to "Always Allow":

After doing that, the Skype Button never goes gray. Instead it reports accurately that you are online or offline or away, etc.
Photo of junis june

junis june

  • 1 Post
  • 0 Reply Likes
Thank you, snooper!

Your solution works and has helped a lot!