SmugMug Gallery Widget Issue

  • 1
  • Problem
  • Updated 5 years ago
  • In Progress
I'm having an issue with a password being required for Smugmug gallery widget. I'm a member of Smugmug and have been using this gallery widget for the last three years on Yola with no problem. I have tried copying the link by being logged into Smugmug and logged out. It also shows a password required for the generic gallery link that automatically populates in the widget when you drag it from the tool bar as well, so this makes me think it might not be my gallery. I do not have passwords set through SmugMug, so I know that is not the answer. I need a fix asap, so thank in advance for your assistance.
Photo of Ashley Woods

Ashley Woods

  • 1 Post
  • 0 Reply Likes
  • frustrated.

Posted 5 years ago

  • 1
Photo of Stefan

Stefan, Official Rep

  • 4448 Posts
  • 190 Reply Likes
Hello Ashley

We are currently experiencing a problem with users adding the URL of their own SmugMug gallery to the Yola's SmugMug Widget in the Sitebuilder. Our engineers are busy looking into this issue.

As a workaround, you could add your SmugMug gallery to your Yola website by using HTML code SmugMug provides to embed galleries on websites. Please follow these steps:
  1. Log into your SmugMug account and make sure that your gallery is not password-protected. If it is, it cannot be embedded into a website. To check this, please click on your gallery, then on "Customize" at the top, choose "Gallery Settings", then "Security & Privacy". In the Password boxes it should say "optional".

  2. Go back to your gallery and click on the "Share" icon below any of your pictures.

  3. Select "Show off".

  4. Configure your gallery by clicking on "Configure Options".

  5. Once done, click on "Copy Embed Code". Now the code has been copied to your clipboard.

  6. Go back to the Sitebuilder with your Yola website and paste the code into an HTML Code Widget which you drag and drop onto your page.

Your SmugMug gallery should now display in Preview.