Struggling to update in the Sitebuilder

  • 1
  • Question
  • Updated 3 years ago
  • Answered
I live in Maryland, United States and I really cant update my website because of site builder being a slowpoke. I tried to update my website but it is very slow and i have been waiting for several hours to do an update that should only take 30 minutes and its still loading. please HELP! My website is and it's hosted Yola. If you couldn't already tell or Jake's Weather Blog is a Weather forecasting data collection company and we have clients  that rely on our online forecasts, which is on a website hosted by Yola. So y'all better do something about this or we will lose a ton of business. What the heck is your customer service phone number?

Note: This conversation was created from a reply on: Yola site editor extremely slow - unresponsive.
Photo of Jake Goodman

Jake Goodman

  • 2 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Laura Thomas

Laura Thomas, Social Media Coordinator

  • 4536 Posts
  • 211 Reply Likes
Hi Jake,

I created a new topic for you as the thread you posted on was several years old. I also loaded in your Sitebuilder to see if I could detect a lag. Everything seemed snappy and responsive to me on Firefox and Chrome, but I didn't want to make any changes without your permission. If you want to share the specific page and update you were struggling with I'm happy to test that with your permission. In the meantime please take a look at the initial troubleshooting section of this tutorial and let me know if that helps.